Bug 812985 - GNOME desktop screenshot behavior non-intuitive, non-useful
GNOME desktop screenshot behavior non-intuitive, non-useful
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-screenshot (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 13:45 EDT by Jonathan Kamens
Modified: 2012-04-19 23:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 23:28:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-04-16 13:45:06 EDT
When I use the Print or Alt-Print button to take a picture of the screen or a window in GNOME, it flashes briefly to let me know that the picture has been taken, but I have no idea where it went.

It turns out that it was saved as a file in my ~/Pictures directory. I had no idea.

I think it used to pop up a window asking what you wanted to do with the screen shot. This was much more useful behavior.

Personally, I think the default should be to copy it into the clipboard, not to save it into a file in a directory I don't use for anything else and never look at.

Alternatively, it could save it to a file _and_ copy it to the clipboard. That would be useful too.

It would be nice if the default behavior were configurable.

It would be nice if a notification popped up indicating what was done.

In short, the current functionality is opaque; at the very least it needs to be more obvious what happened (e.g. notification), but even better would be to improve the behavior using one or more of the ideas listed above.
Comment 1 Matthias Clasen 2012-04-19 21:29:56 EDT
Follow the upstream discussion here: https://bugzilla.gnome.org/show_bug.cgi?id=669629

Note You need to log in before you can comment on or make changes to this bug.