Bug 813072 - include nssdbgen in rhui install
include nssdbgen in rhui install
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 15:55 EDT by wes hayutin
Modified: 2012-08-24 07:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat Update Infrastructure uses an NSS database to secure QPID communication. NSS database generation was a user interactive process during rh-rhui-tools installation. This update automates the NSS database generation and configuration with the nss-db-gen script during the rh-rhui-tools installation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:54:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to allow nss-db-gen to run w/o user interaction (1.45 KB, patch)
2012-05-16 16:09 EDT, wes hayutin
no flags Details | Diff
patch for install_tools to automatically run nss-db-gen (883 bytes, patch)
2012-05-16 16:27 EDT, wes hayutin
no flags Details | Diff
Verifying screen log (9.07 KB, text/plain)
2012-07-30 12:30 EDT, mkovacik
no flags Details

  None (edit)
Description wes hayutin 2012-04-16 15:55:38 EDT
Description of problem:
per conversation w/ Chris and Slagle

1.  Run nss-db-gen automagically and store info somewhere in /etc/pulp and update answers file.
2. Remark out the nss-db-gen lines in the default sample answer file
3. Change the directories in default sample answer file
Comment 1 wes hayutin 2012-05-16 14:55:45 EDT
You can get nss-db-gen to run w/o user prompts w/ the following edits..

just an example..


 sed -i s/'DB_PASSWORD=""'/'DB_PASSWORD="dog8code"'/g /usr/bin/nss-db-gen
 sed -i s/'read -p'/'#read -p'/g /usr/bin/nss-db-gen
 sed -i s/'read -sp'/'#read -sp'/g /usr/bin/nss-db-gen
 sed -i s/'-o client.p12'/'-o client.p12 -w $PWDFILE -W $DB_PASSWORD -k $PWDFILE -K $DB_PASSWORD'/g /usr/bin/nss-db-gen
 sed -i s/'openssl pkcs12 -in client.p12 -nodes -out client.crt'/'openssl pkcs12 -in client.p12 -nodes -out client.crt -password file:$PWDFILE'/g /usr/bin/nss-db-gen
Comment 2 wes hayutin 2012-05-16 16:09:46 EDT
Created attachment 585051 [details]
patch to allow nss-db-gen to run w/o user interaction
Comment 3 wes hayutin 2012-05-16 16:27:31 EDT
Created attachment 585055 [details]
patch for install_tools to automatically run nss-db-gen
Comment 4 wes hayutin 2012-05-18 15:28:31 EDT
cloude commit d2657e7f6465774e1dbbf097900df28eae8bb026
Comment 5 wes hayutin 2012-05-21 14:08:43 EDT
had to also update the sample answers file

commit 1921d3f5423505ffd14b351e1bb297d8e6fbb212
Comment 6 mkovacik 2012-07-30 12:30:43 EDT
Created attachment 601308 [details]
Verifying screen log

Verified that
- the patch is present in rh-rhui-tools version 2.1.4 (build RHEL-6.3-RHUI-2.1-20120719.0-Server-x86_64-DVD1.iso)
- the nss-db-gen script is part of the install_tools.sh script in that version
- the nss-db-gen in that version doesn't require user interaction while generating qpid nss stuff
See the screen log attached
Comment 7 Dan Macpherson 2012-08-14 01:04:30 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Red Hat Update Infrastructure uses an NSS database to secure QPID communications. NSS database generation was a user interactive process during rh-rhui-tools installation. This update automates the NSS database generation and configuration with the nss-db-gen script during the rh-rhui-tools installation.
Comment 8 Dan Macpherson 2012-08-14 03:22:54 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Red Hat Update Infrastructure uses an NSS database to secure QPID communications. NSS database generation was a user interactive process during rh-rhui-tools installation. This update automates the NSS database generation and configuration with the nss-db-gen script during the rh-rhui-tools installation.+Red Hat Update Infrastructure uses an NSS database to secure QPID communication. NSS database generation was a user interactive process during rh-rhui-tools installation. This update automates the NSS database generation and configuration with the nss-db-gen script during the rh-rhui-tools installation.
Comment 10 errata-xmlrpc 2012-08-24 07:54:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.