Bug 813074 - replace rpm commands w/ yum
replace rpm commands w/ yum
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 15:57 EDT by wes hayutin
Modified: 2012-08-24 07:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat Update Infrastructure installation scripts used depreciated commands for rpm installation on Red Hat Enterprise Linux (RHEL) 6. This update replaces the instances of depreciated commands with the recommend "yum install" command, which ensures successful installation on RHEL 6.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:54:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum command patch (1.80 KB, patch)
2012-05-16 10:16 EDT, wes hayutin
no flags Details | Diff
Verifying screen log (1.62 KB, text/plain)
2012-07-30 08:28 EDT, mkovacik
no flags Details

  None (edit)
Description wes hayutin 2012-04-16 15:57:21 EDT
Description of problem:

When installing on RHEL6x its now preferred to use either:
1. yum localinstall 
2. yum install rpm  (same thing as local install)
Comment 1 wes hayutin 2012-05-16 10:15:30 EDT
"""
http://docs.fedoraproject.org/en-US/Fedora/14/html/Software_Management_Guide/ch05s05s03.html

The yum localinstall command is deprecated, use the form yum install.
"""

I tested just using "yum install" and it works fine
Comment 2 wes hayutin 2012-05-16 10:16:07 EDT
Created attachment 584980 [details]
yum command patch
Comment 3 wes hayutin 2012-05-18 15:08:13 EDT
cloude commit d19a1d19f56042835e4ea17a224f93aa90e9268d
Comment 4 mkovacik 2012-07-30 08:28:45 EDT
Created attachment 601246 [details]
Verifying screen log

The installation scripts of build RHEL-6.3-RHUI-2.1-20120705.0-Server-x86_64-DVD1.iso do not contain rpm installation commands. 'yum localinstall' is being used instead. See the screen log attached.
Comment 5 Dan Macpherson 2012-08-14 01:09:31 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Red Hat Update Infrastructure installation scripts used depreciated commands for rpm installation on Red Hat Enterprise Linux (RHEL) 6. This update replaces the instances of depreciated commands with the recommend "yum install" command, which ensures successful installation on RHEL 6.
Comment 7 errata-xmlrpc 2012-08-24 07:54:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.