Bug 813090 - v7 plan fails when the Hardware Catalog Server is not reachable from the SUT
v7 plan fails when the Hardware Catalog Server is not reachable from the SUT
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
: 813213 (view as bug list)
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-04-16 16:45 EDT by chau nguyen
Modified: 2015-02-08 16:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RH61x64 error (1.06 KB, text/plain)
2012-04-16 16:45 EDT, chau nguyen
no flags Details
RH6.2x64 error (981 bytes, text/plain)
2012-04-16 16:46 EDT, chau nguyen
no flags Details
catalog.py patch fixing traceback when catalog is unreachable (493 bytes, patch)
2012-04-17 11:29 EDT, Greg Nichols
no flags Details | Diff
RHEL6_x64_Patch details (137.05 KB, image/jpeg)
2012-04-18 09:25 EDT, Akash Kodenkiri
no flags Details

  None (edit)
Description chau nguyen 2012-04-16 16:45:59 EDT
Created attachment 577835 [details]
RH61x64 error

How reproducible:
Unable install new v7-1.5-18 test kit on RH6.2 and RH6.1


Steps to Reproduce:
1.Install RH6.1x64
2.Install V7-1.5-18
3.Type command line v7 plan
  
Actual results:
Unable to create v7 test plan

Expected results:
Create v7 test plan

Additional info:

[root@SUT-DL380G7 rh6_x64]# v7 plan
found interface for udisks
found device file /dev/sda
found device file /dev/sdb
Please verify the vendor, make, and model:
Vendor: HP
Make: ProLiant
Model: ProLiant DL380 G7
Hardware: HP ProLiant ProLiant DL380 G7
OS: Santiago 6.1
Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in <module>
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 194, in do
    result = self.commands[self.command]()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 325, in doPlan
    self.doDiscover()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 249, in doDiscover
    self.catalog.getCertificationID(self.certification)
  File "/usr/share/v7/lib/v7/catalog.py", line 53, in getCertificationID
    if not self.isReachable():
  File "/usr/share/v7/lib/v7/catalog.py", line 47, in isReachable
    print "Could not reach catalog server %s" % catalogServer
NameError: global name 'catalogServer' is not defined
[root@SUT-DL380G7 rh6_x64]# ^C
Comment 1 chau nguyen 2012-04-16 16:46:39 EDT
Created attachment 577837 [details]
RH6.2x64 error
Comment 4 Greg Nichols 2012-04-17 11:29:53 EDT
Created attachment 578078 [details]
catalog.py patch fixing traceback when catalog is unreachable
Comment 5 Greg Nichols 2012-04-17 11:32:55 EDT
*** Bug 813213 has been marked as a duplicate of this bug. ***
Comment 7 Rob Landry 2012-04-17 13:35:02 EDT
chau.nguyen2, akodenkiri,

Are you able to continue after applying the patch in Comment #4?

Thanks,

-Rob

From my testing the patch works but prompts for a certID where a "0" will get past this prompt (Bug #813405).
Comment 9 Rob Landry 2012-04-17 13:38:31 EDT
(In reply to comment #7)
> chau.nguyen2, akodenkiri,
> 
> Are you able to continue after applying the patch in Comment #4?
> 
> Thanks,
> 
> -Rob
> 
> From my testing the patch works but prompts for a certID where a "0" will get
> past this prompt (Bug #813405).

Applying the patch will also cause the info test to fail the v7 validation step.  This is expected behavior.
Comment 12 Akash Kodenkiri 2012-04-18 07:58:54 EDT
Hi Rob,

Can you tell me how to apply this patch?. A brief steps will help a lot.


-Akash
Comment 13 Greg Nichols 2012-04-18 09:01:39 EDT
The file to be patched is 

/usr/share/v7/lib/v7/catalog.py

Assuming you've saved the attachment to a file catalog.patch, the command to patch it would be:

> patch /usr/share/v7/lib/v7/catalog.py catalog.patch

Thanks!
Comment 14 Akash Kodenkiri 2012-04-18 09:25:25 EDT
I have followed your instruction to apply patch and it got applied without any issue.If i enter "v7 plan" i am not getting any crash but it asks us to enter Certification ID.I don't what certification ID has to enter here. There was no instruction to enter Certification ID on v1.4 kit.Is there any new step is required.?

Please find attached "RHEL6_x64_patch.JPG" snapshot for more details

-Akash
Comment 15 Akash Kodenkiri 2012-04-18 09:25:57 EDT
Created attachment 578351 [details]
RHEL6_x64_Patch details
Comment 16 Rob Landry 2012-04-18 09:50:53 EDT
(In reply to comment #14)
> I have followed your instruction to apply patch and it got applied without any
> issue.If i enter "v7 plan" i am not getting any crash but it asks us to enter
> Certification ID.I don't what certification ID has to enter here. There was no
> instruction to enter Certification ID on v1.4 kit.Is there any new step is
> required.?

A CertID of "0" will bypass this prompt.  This is a bug, and is being tracked ing Bug #813405.
Comment 17 Akash Kodenkiri 2012-04-19 02:19:29 EDT
Thanks. I executed the test by providing "0" as Cert ID. Info and Core tests failed for me. FWIW these tests passed with v1.4 kit. Probably you have another bug here.



-Akash
Comment 18 Rob Landry 2012-04-19 10:00:04 EDT
Hi Akash,

The info is expected to fail with the patch applied.  The self checks will fail since the test has been modified.  If you check the logs the only expected fail is the self check, others would be something else.

Core should not be related to this bug or the patch.  If you can check the core logs and decide if it looks like a bug.  If so it's worth opening a new bug for that.

-Rob
Comment 23 Caspar Zhang 2012-06-04 04:04:30 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 25 errata-xmlrpc 2012-06-05 17:37:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.