Bug 813147 - Header message needs to be fixed while uploading an invalid xml in application blueprint
Header message needs to be fixed while uploading an invalid xml in applicatio...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Jan Provaznik
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 01:30 EDT by Shveta
Modified: 2012-12-04 10:03 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The validation message for invalid XML displayed 'Application Blueprint XML' twice in the header. This fix revises the warning message code. The term 'Application Blueprint XML' no longer repeats.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:03:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
header_message (219.80 KB, image/png)
2012-04-17 01:30 EDT, Shveta
no flags Details
blank XML field (82.29 KB, image/png)
2012-09-20 17:29 EDT, Ronelle Landy
no flags Details
not Valid XML uploaded (86.07 KB, image/png)
2012-09-20 17:29 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Shveta 2012-04-17 01:30:39 EDT
Created attachment 577877 [details]
header_message

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. As shown in the screenshot , header message says : "Application Blueprint XML Application Blueprint XML file doesn't resolve valid XML file "
2. Application Blueprint XML is repeated ..
3.
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
Comment 3 Jan Provaznik 2012-08-30 09:02:33 EDT
a patch is waiting for a review: https://lists.fedorahosted.org/pipermail/aeolus-devel/2012-August/012353.html
Comment 4 Jan Provaznik 2012-09-04 10:09:35 EDT
pushed, commit in master: 73db059e1a210e6e7b93ba7c612a0a864d0626ee
Comment 5 Steve Linabery 2012-09-07 17:52:53 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 7 Ronelle Landy 2012-09-20 17:28:12 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

See two attached screenshots ... the first when the XML field is empty, and the second when an invalid file is entered.

Marking this BZ as 'verified' an neither message (shown in the screenshots) repeats 'Application Blueprint'.
Comment 8 Ronelle Landy 2012-09-20 17:29:06 EDT
Created attachment 615129 [details]
blank XML field
Comment 9 Ronelle Landy 2012-09-20 17:29:32 EDT
Created attachment 615130 [details]
not Valid XML uploaded
Comment 11 errata-xmlrpc 2012-12-04 10:03:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.