This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 813153 - DHT: Directory self heal fails
DHT: Directory self heal fails
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 01:48 EDT by Sachidananda Urs
Modified: 2013-12-08 20:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 04:42:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs for directory self-heal failure (14.96 MB, application/x-bzip)
2012-04-17 01:48 EDT, Sachidananda Urs
no flags Details

  None (edit)
Description Sachidananda Urs 2012-04-17 01:48:51 EDT
Created attachment 577882 [details]
Logs for directory self-heal failure

When I run a few rename tests, the setup ends in a situation where the directories are present in a few nodes and go missing in a few nodes.

Later execution of `ls' sometimes lists the directories and sometimes they are not listed. Ideally, upon doing a stat on the directories should trigger self-heal and the missing directories have to be created, but no such thing happens.

Logs don't say much about directory self-heal. However, attaching the logs with the ticket.
Comment 1 shishir gowda 2012-06-07 02:43:20 EDT
Is this bug still reproducable?
Comment 2 shishir gowda 2012-06-07 04:42:35 EDT
The reporter (Sachidananda Urs) confirms that the issue is no more seen in release-3.3 (RC1) or upstream.
Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.