Bug 813155 - create app with latest rhc client return 'execution expired' error and app created successfully on the instance
create app with latest rhc client return 'execution expired' error and app cr...
Status: CLOSED DUPLICATE of bug 813110
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Regression
: 813265 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 01:51 EDT by Meng Bo
Modified: 2013-01-10 20:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 13:25:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-04-17 01:51:03 EDT
Description of problem:
try to create app via rhc client on Mac with latest rhc client 0.90.6, it will return 'execution expired' error from the client side, and the app was created successfully on the instance.

Version-Release number of selected component (if applicable):
rhc-0.90.6
rhc-rest-0.0.14

How reproducible:
always

Steps to Reproduce:
1.install rhc client 0.90.6 on Mac
gem install rhc --source http://$libra_repo/ --version=0.90.6
2.try to create app with user has domain
3.
  
Actual results:
create app will return 'execution expired' error, and the app created successfully on the instance.

Expected results:
correct output returns when creating app

Additional info:
this issue does not happen on rhc-0.90.5 on Mac.
this issue does not happen on rhc-0.90.6 on RHEL and Fedora.
Comment 1 Meng Bo 2012-04-17 03:38:15 EDT
According to this comment https://bugzilla.redhat.com/show_bug.cgi?id=813110#c1

This issue also happens on Linux with latest rhc client(0.91.1).

And after check the /usr/lib/ruby/gems/1.8/user-gems/rhc-0.90.6/lib/rhc-common.rb on Mac, it also has the line "http.open_timeout = @mytimeout"
Comment 2 Xiaoli Tian 2012-04-17 09:28:51 EDT
*** Bug 813265 has been marked as a duplicate of this bug. ***
Comment 3 Rob Millner 2012-04-17 13:25:20 EDT

*** This bug has been marked as a duplicate of bug 813110 ***

Note You need to log in before you can comment on or make changes to this bug.