Bug 813160 - Starts to early for network services.
Starts to early for network services.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 02:11 EDT by Robin Laing
Modified: 2012-09-19 20:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 00:12:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Laing 2012-04-17 02:11:47 EDT
Description of problem:
Autofs starts before all network services are ready.  Remote drives are not selected until autofs is restarted.

Version-Release number of selected component (if applicable):
autofs-5.0.6-5.fc16.x86_64

How reproducible:
Every reboot.

Steps to Reproduce:
1. Shutdown or restart machine.
2. Try to login using ldap and remote home directories.
3. Home directory not found.
  
Actual results:
Home directory is not mounted as expected.

Expected results:
Home directory should be mounted via autofs after a reboot without having to restart the service.

Additional info:
Once the boot/reboot sequence is completed, if I restart autofs (service autofs restart).  Everything works as expected.  In the past I would just change the number for the boot start-up but it has been changed back on a reboot or upgrade.
Comment 1 Ian Kent 2012-04-17 05:47:22 EDT
Assuming you are using NetworkManager, try enabling the 
NetworkManager-wait-online.service.

I believe NetworkManager will return control to systemd
before the network is actually available.
Comment 2 Robin Laing 2012-05-15 00:12:15 EDT
I finally got a chance to test this on the affected machine.

NetworkManager-wait-online.service

Seems to have fixed the problem.  I guess there are lots of things to learn with the move to systemd.

I guess this is really not a bug but a change in how the system boots.  Changing the process number didn't work as before.
Comment 3 Ian Kent 2012-09-19 20:56:42 EDT
*** Bug 858848 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.