Bug 813200 - SELinux errors with appliance-creator
SELinux errors with appliance-creator
Status: CLOSED DUPLICATE of bug 812297
Product: Fedora
Classification: Fedora
Component: appliance-tools (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Huff
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-17 04:32 EDT by Marko Myllynen
Modified: 2012-10-15 10:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-15 10:44:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-04-17 04:32:56 EDT
Description of problem:
When using appliance-creator with the host SELinux is in Permissive mode, the following errors are being printed (but the appliance image is still being built) - the last SELinux complaint is printed even with selinux --disabled, the former with selinux --permissive / selinux --enforcing.

Removing password for user root.
passwd: Success
Installation finished. No error reported.
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.3.0-0.rc3.git7.2.fc17.x86_64
Found initrd image: /boot/initramfs-3.3.0-0.rc3.git7.2.fc17.x86_64.img
/etc/selinux/targeted/contexts/files/file_contexts: line 2352 has invalid
context system_u:object_r:xfs_exec_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 2585 has invalid
context system_u:object_r:xfs_exec_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 3162 has invalid
context system_u:object_r:xfs_exec_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 3610 has invalid
context system_u:object_r:xfs_exec_t:s0
Unmounting directory /var/tmp/imgcreate-9gzrRx/install_root/
Losetup remove /dev/loop0
umount: /var/tmp/imgcreate-9gzrRx/install_root/sys/fs/selinux/load: not found

See bug 812298 for the example kickstart file if needed.

Version-Release number of selected component (if applicable):
Fedora 17 Beta
Comment 1 Matthew Miller 2012-10-15 10:44:29 EDT

*** This bug has been marked as a duplicate of bug 812297 ***

Note You need to log in before you can comment on or make changes to this bug.