Bug 813202 - libreoffice-ogltrans is dependency of libreoffice-impress
libreoffice-ogltrans is dependency of libreoffice-impress
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 04:33 EDT by Bastián Díaz
Modified: 2012-05-26 03:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-3.5.3.2-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:15:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
x.org log file requested (23.95 KB, text/plain)
2012-04-21 07:13 EDT, Bastián Díaz
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 33333 None None None Never

  None (edit)
Description Bastián Díaz 2012-04-17 04:33:25 EDT
Description of problem:
The problem is the installation the package "libreoffice-ogltrans" with the rest of the packages of "libreoffice". It acts as a dependency of "libreoffice-impress". This decreases the performance of presentations on computers without powerful graphics cards (even turned off hardware acceleration in "libreoffice")

Version-Release number of selected component (if applicable):
Fedora 17 (Nightly live 20120416.08) | Libreoffice 3.5

How reproducible:
Install "libreoffice" or "libreoffice-impress" and then uninstall the package "libreoffice-ogltrans".

Steps to Reproduce:
1. Install "libreoffice/libreoffice-impress"
2. Remove package "libreoffice-ogltrans"
  
Actual results:
By removing the package "libreoffice-ogltrans" further requests uninstall "libreoffice-impress" and "libreoffice-presenter-screen".

Expected results:
remove "libreoffice-ogltrans" ("libreoffice-impress" is operating in the system)

Additional info:
I have seen this problem has been maintained for 3 weeks waiting for it to be resolved before the beta version (thinking it is a known bug). In my case, I occupy a small netbook for my presentations at the university, but it occupies only the transition fade to black, there are difficulties on the screen (testing the system, I occupy daily fedora 16).
Comment 1 Caolan McNamara 2012-04-17 04:56:49 EDT
caolanm->dtardon: have a quick look at this ? I don't think having the opengl transitions installed should affect the standard fade-to-black transition.

caolanm->diaz: You can always test this theory with a rpm --erase --nodeps libreoffice-ogltrans and see if it makes a difference to you or if the problem persists and is unrelated to the opengl slide transitions.
Comment 2 Bastián Díaz 2012-04-17 05:57:36 EDT
(In reply to comment #1)

I can explain the problem, as above (since Fedora 15) I intend to test the 3D transitions and realized the problems I had when viewing the presentations with the majority of transitions (not all).

This I have tested in Vaio-VPCW210AL; Vaio-VPCYB35AL and a desktop computer (integrated card) with the same results.

Regarding what you mentioned, I did try installing the packages manually (without "libreoffice-ogltrans") and as you proposed and transitions work perfectly (I did the same in fedora 16 manually, and also from the repositories but the problem remains the package "libreoffice-ogltrans".

Before I forget, the case of the transition "fade-to-black" was just an example to be a simple transition but curiously is greatly affected in their visualization with the package "libreoffice-ogltrans" installed.

All I propose is that the package "libreoffice-ogltrans" is not a dependency of "libreoffice-impress". Each user decides whether or not to install this package (depending on your hardware).
Comment 3 David Tardon 2012-04-17 06:19:45 EDT
Actually(In reply to comment #1)
> caolanm->dtardon: have a quick look at this ? I don't think having the opengl
> transitions installed should affect the standard fade-to-black transition.

Actually the OGLTrans implements several of the "simple" transitions, FADE/FADEOVERCOLOR being one of them. I suppose the idea behind it is that it should be faster than software rendering through whatever canvas impl. is used ATM. The impl. does nothing special, just a texture and some alpha blending. And it is disabled for Mesa (though I do not understand why the test for that is in createTransition and not in hasTransition already...)
Comment 4 David Tardon 2012-04-17 06:24:40 EDT
(In reply to comment #2)
> (In reply to comment #1)
> 
> Before I forget, the case of the transition "fade-to-black" was just an example
> to be a simple transition but curiously is greatly affected in their
> visualization with the package "libreoffice-ogltrans" installed.
> 
> All I propose is that the package "libreoffice-ogltrans" is not a dependency of
> "libreoffice-impress". Each user decides whether or not to install this package
> (depending on your hardware).

The dependency was added deliberately, based on the fact that both major desktop environments in Fedora (Gnome 3 and KDE 4) actually require working 3D. Because rpm still does not support any form of Suggests/Recommends, hard-coded Requires is the only way to install additional packages...
Comment 5 Bastián Díaz 2012-04-17 06:48:01 EDT
(In reply to comment #4)

> The dependency was added deliberately, based on the fact that both major
> desktop environments in Fedora (Gnome 3 and KDE 4) actually require working 3D.
> Because rpm still does not support any form of Suggests/Recommends, hard-coded
> Requires is the only way to install additional packages...

I understand that both GNOME and KDE require working 3D, but for example in GNOME has been controversial "GNOME-Shell" that requires hardware acceleration. My computer supports "GNOME-Shell" and considering that no more than 2 years, does not support the transitions that integrates the package "libreoffice-ogltrans" (as computers that name in the comment 2).

By this I start to think about others who may have the same difficulties and reduced that would become the target users of Fedora 17 (which could use the 3D capabilities of GNOME-Shell and now Libreoffice-impress).

Moreover 3D transitions are not available on other platforms, creating difficulties in interoperability and a real treat for presentations only from GNU / Linux.

Therefore, from my perspective I insist that the package "libreoffice-ogltrans" should not be a dependency of "libreoffice-impress" but an optional package, as it has in other versions of fedora.
Comment 6 Caolan McNamara 2012-04-20 06:44:16 EDT
What we could do here for the general case is...

a) find out what driver you have first, (attach your /var/log/Xorg.0.log here)
b) get a list of what transitions are super-slow (all of them ?, or just some)
then we might be able to get some test-cases to the X team, especially if gnome-shell is working well, there's clearly something wrong if the transitions are slow while that's acceptable
c) we could tweak things so that we don't require the opengl transitions from impress for e.g. F-17, but tweak the F-17 comps to select them for installation by default when LibreOffice is getting installed, which enables them to be removed if they don't work out on some given hardware

so, let's get the /var/log/Xorg.0.log anyway
Comment 7 Bastián Díaz 2012-04-21 07:13:15 EDT
Created attachment 579157 [details]
x.org log file requested

Requested log file attached. It belongs to a Vaio computer VPCW210AL video card Intel GMA 3150.
I hope to attach during the day x.org log files on other computers I mentioned. The desktop works with intel integrated video card, but the other computer uses a video card AMD Radeon HD 6310 (supports more workload but has the same problems).
Comment 8 Bastián Díaz 2012-04-21 07:34:30 EDT
(In reply to comment #6)

About the list of transitions that has requested me, I started testing and I found that there are a set of transitions are not displayed correctly (with or without OGLtrans). While the other transitions are displayed correctly, 3D transitions affect the performance of the other transitions (and even more when including images, graphics, custom backgrounds or videos) to be a problem ursarlos for a presentation.

Transitions with problems (without OGLtrans).
→ Set of transitions "uncover" have a bad display.
→ The transition "cut through black" is not displayed.
→ set of transitions "cover" have a bad display.

http://dl.dropbox.com/u/5204736/Test%20whithout%20ogltrans.webm

Transitions with problems (with OGLtrans) (every one is some slow)
→ set of transitions "cover" and "uncover" bad display is maintained.
→ The transition "cut through black" has slow startup and not displayed.
→ The transition "fade-through black" has slow startup and not displayed.
→ The transition "fade Smoothly" is not displayed.
The set of transitions → 3D has a slow start.
→ Transitions "static" and "fine dissolve" are not displayed.

http://dl.dropbox.com/u/5204736/Test%20ogltrans.webm

I included videos so they can see what problems are treated.
(Where I can report other bugs I found in Impress?)
Comment 9 Caolan McNamara 2012-05-09 08:02:04 EDT
yeah, lots of baddies here still. Lets punt the hard depend on ogltrans for F17 and have a second go at fixing the individual problems for F18 in LibO and/or various X drivers, whereever the individual problems lie.
Comment 10 Fedora Update System 2012-05-09 15:15:47 EDT
libreoffice-3.5.3.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.3.2-3.fc17
Comment 11 Fedora Update System 2012-05-10 16:41:46 EDT
Package libreoffice-3.5.3.2-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.3.2-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7635/libreoffice-3.5.3.2-3.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-05-26 03:15:31 EDT
libreoffice-3.5.3.2-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.