Bug 813203 - vim.py is missing, should be suplied with one of the vim packages
vim.py is missing, should be suplied with one of the vim packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 04:39 EDT by Angus Salkeld
Modified: 2014-01-12 20:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 07:21:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angus Salkeld 2012-04-17 04:39:44 EDT
Description of problem:

Many vim plugins use vim.py and don't function without this.
vim is complied with python support but seems like this
file was ommitted.

Version-Release number of selected component (if applicable):
 vim --version
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Feb 13 2012 12:19:21)
Included patches: 1-415, 417-444

Note: it has +python 

How reproducible:
100%

Steps to Reproduce:
1.python
2.import vim
3.
  
Actual results:
>>> import vim
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named vim


Expected results:
no exception.

Additional info:
I am trying to use:

ultisnips: http://www.vim.org/scripts/script.php?script_id=2715

also: https://dev.launchpad.net/UltimateVimPythonSetup

example:
" `gf` jumps to the filename under the cursor.  Point at an import statement
" and jump to it!
python << EOF
import os
import sys
import vim
for p in sys.path:
    if os.path.isdir(p):
        vim.command(r"set path+=%s" % (p.replace(" ", r"\ ")))
EOF
Comment 1 Karsten Hopp 2012-08-28 07:21:19 EDT
There is no such file like vim.py. The ultisnips scripts is intended to run within vim, not as a python.
Please read the instructions at 
http://www.vim.org/scripts/script.php?script_id=2715

Note You need to log in before you can comment on or make changes to this bug.