Bug 813218 - Component Outline Id should be renamed to image UUID in import image tab
Component Outline Id should be renamed to image UUID in import image tab
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tzu-Mainn Chen
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 05:17 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The upper and lower text fields in the Import Image dashboard were labelled incorrectly. This update corrects the field text.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:04:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
problem snapshot (157.80 KB, image/png)
2012-04-17 05:17 EDT, pushpesh sharma
no flags Details
Image Image - includes 'Component Outline ID' in label text (67.69 KB, image/png)
2012-09-21 09:17 EDT, Ronelle Landy
no flags Details
Labels as required (58.18 KB, image/png)
2012-09-25 11:46 EDT, Ronelle Landy
no flags Details

  None (edit)
Description pushpesh sharma 2012-04-17 05:17:40 EDT
Created attachment 577960 [details]
problem snapshot

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.clouds-->any_specific_cloud--> import_image 
2.
3.
  
Actual results:


Expected results:
component image ID should be renamed to image UUID

Additional info:
Comment 1 pushpesh sharma 2012-04-17 05:18:20 EDT
[root@dhcp201-169 ~]# rpm -qa|grep aeolus
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 2 Angus Thomas 2012-04-19 13:05:07 EDT
The upper text field should be labelled "Provider's Image ID", rather than "Component Outline ID", as in the image.

The lower text field should be labelled "Image name", rather than "Component Outline Name", as in the image.
Comment 6 Tzu-Mainn Chen 2012-08-21 10:20:25 EDT
Patch created:

http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-August/012222.html
Comment 7 Matt Wagner 2012-08-30 11:54:55 EDT
ACK + pushed to master and 1.1.

commit 85c56556ef4e20ab2b94106948138bf56797fa14
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Tue Aug 21 10:19:42 2012 -0400

    BZ 813218 updated image_id label
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit d727b908d4fbc64c9ad73047039498c1b6da6f4b)
Comment 8 Steve Linabery 2012-09-07 17:53:00 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 10 Ronelle Landy 2012-09-21 09:16:37 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

The upper text box label is: Cloud Resource Provider's Component Outline ID

The lower text box label is: Image Name

See the attached screenshot

This contradicts with Comment 2 above  "The upper text field should be labelled "Provider's Image ID", rather than "Component Outline ID", as in the image."

Moving BZ back to Assigned to address ^^.
Comment 11 Ronelle Landy 2012-09-21 09:17:31 EDT
Created attachment 615416 [details]
Image Image - includes 'Component Outline ID' in label text
Comment 12 Tzu-Mainn Chen 2012-09-21 09:56:21 EDT
After talking to Angus, product name should be Cloud Resource Provider's Image ID.  This has been taken care of in a different patch that was applied this week, and should be in the latest brew build:

https://bugzilla.redhat.com/show_bug.cgi?id=783128
Comment 13 Ronelle Landy 2012-09-25 11:45:55 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.7-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch

Labels on the import image page now read: 


Cloud Resource Provider Account
Cloud Resource Provider's Image ID
Image Name

See screenshot attached.
Comment 14 Ronelle Landy 2012-09-25 11:46:31 EDT
Created attachment 617099 [details]
Labels as required
Comment 16 errata-xmlrpc 2012-12-04 10:04:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.