Bug 813220 - eog %pre script fails
eog %pre script fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: eog (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 05:21 EDT by Matěj Cepl
Modified: 2014-06-13 08:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.6.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:18:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2012-04-17 05:21:32 EDT
Description of problem:

wycliff:tmp# LANG=C yum upgrade eog
Loaded plugins: product-id, refresh-packagekit, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Resolving Dependencies
--> Running transaction check
---> Package eog.x86_64 0:3.2.1-2.el7 will be updated
---> Package eog.x86_64 0:3.3.92-1.el7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================
 Package       Arch             Version                 Repository       Size
==============================================================================
Updating:
 eog           x86_64           3.3.92-1.el7            df-ws           2.6 M

Transaction Summary
==============================================================================
Upgrade  1 Package

Total download size: 2.6 M
Is this ok [y/N]: y
Downloading Packages:
eog-3.3.92-1.el7.x86_64.rpm                            | 2.6 MB     00:33     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package eog-3.3.92-1.el7.x86_64
/var/tmp/rpm-tmp.9763qo: line 1: fg: no job control
error: %pre(eog-3.3.92-1.el7.x86_64) scriptlet failed, exit status 1
Installed products updated.
  Verifying  : eog-3.3.92-1.el7.x86_64                                    1/2 
eog-3.2.1-2.el7.x86_64 was supposed to be removed but is not!
  Verifying  : eog-3.2.1-2.el7.x86_64                                     2/2 

Failed:
  eog.x86_64 0:3.2.1-2.el7              eog.x86_64 0:3.3.92-1.el7             

Complete!
--------------------------------------------------------------------------
When looking at the scripts:

wycliff:tmp# rpm -qp --scripts eog-3.3.92-1.el7.x86_64.rpm 
preinstall scriptlet (using /bin/sh):
%gconf_schema_obsolete eog
postinstall scriptlet (using /bin/sh):
update-desktop-database -q
touch /usr/share/icons/hicolor >&/dev/null || :
postuninstall scriptlet (using /bin/sh):
update-desktop-database -q
if [ $1 -eq 0 ]; then
  touch --no-create /usr/share/icons/hicolor >&/dev/null || :
  gtk-update-icon-cache /usr/share/icons/hicolor >&/dev/null || :
  glib-compile-schemas /usr/share/glib-2.0/schemas
fi
posttrans scriptlet (using /bin/sh):
gtk-update-icon-cache /usr/share/icons/hicolor >&/dev/null || :
glib-compile-schemas /usr/share/glib-2.0/schemas
wycliff:tmp# 

it seems to me obvious, that >& is wrong. I guess you meant 2>/dev/null, right?

Version-Release number of selected component (if applicable):
eog-3.3.92-1.el7

How reproducible:
100%
Comment 4 Matthias Clasen 2013-01-02 12:57:42 EST
>& is fine, as far as I can see.
But the %pre script does not exist anymore, so the issue is most likely moot.
Comment 5 Vladimir Benes 2013-01-14 06:24:51 EST
no issues any more in version 3.6.2-1.el7
-> VERIFIED
Comment 6 Ludek Smid 2014-06-13 08:18:21 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.