Bug 813224 - Auto subscribe in GUI is failed with dry-run error
Auto subscribe in GUI is failed with dry-run error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
: TestBlocker
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-17 05:26 EDT by yu zheng
Modified: 2012-06-20 09:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:09:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yu zheng 2012-04-17 05:26:00 EDT
Description of problem:
Auto subscribe in GUI is failed with network error. The SLA dry-run result could not be got. 

Version-Release number of selected component (if applicable):
subscription-manager-0.99.14-1.el6.x86_64
python-rhsm-0.99.8-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.Open subscription-manager GUI
# subscription-manager-gui
2.Click "Register" button, register and autosubscribe with account stage_test_12
  
Actual results:
A "network error" dialog pops up. System is registered and not subscribed.

Expected results:
System is registered and auto subscribed.

Additional info:
1.Error message in rhsm.log
2012-04-17 17:07:41,477 [DEBUG]  @connection.py:329 - Making request: GET /subscription/consumers/d8aaf6e6-f6d5-455a-a4a8-f2629eb53e61/entitlements/dry-run?service_level=PREMIUM
2012-04-17 17:07:42,909 [DEBUG]  @connection.py:343 - Response status: 405
2012-04-17 17:07:42,909 [ERROR]  @connection.py:360 - No JSON object could be decoded
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 358, in validateResponse
    parsed = json.loads(response['content'])
  File "/usr/lib64/python2.6/site-packages/simplejson/__init__.py", line 307, in loads
    return _default_decoder.decode(s)
  File "/usr/lib64/python2.6/site-packages/simplejson/decoder.py", line 335, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib64/python2.6/site-packages/simplejson/decoder.py", line 353, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
2012-04-17 17:07:42,910 [ERROR]  @connection.py:361 - Response: {'content': '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"\n       "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">\n<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">\n<head>\n  <meta http-equiv="content-type" content="text/html;charset=UTF-8" />\n  <title>405 Method Not Allowed</title>\n  <link href="/clonepin/stylesheets/scaffold.css?1334240527" media="screen" rel="stylesheet" type="text/css" />\n  <link href="/clonepin/stylesheets/errorpage.css?1334240527" media="screen" rel="stylesheet" type="text/css" />\n</head>\n<body>\n\n  <div class="dialog">\n    <h1>Method Not Allowed</h1>\n    <p>\n      The requested method GET is not allowed for the URL /candlepin/consumers/d8aaf6e6-f6d5-455a-a4a8-f2629eb53e61/entitlements/dry-run.\n    </p>\n  </div>\n\n\n\n</body>\n</html>\n', 'status': 405, 'candlepin_version': None}

2.Try to do dry-run
# curl -k --cert /etc/pki/consumer/cert.pem --key /etc/pki/consumer/key.pem https://subscription.rhn.stage.redhat.com/subscription/consumers/a95a92bf-bb96-4b7c-ad0f-8f6b75164dee/entitlements/dry-run?service_level=Premium
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
       "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
  <meta http-equiv="content-type" content="text/html;charset=UTF-8" />
  <title>405 Method Not Allowed</title>
  <link href="/clonepin/stylesheets/scaffold.css?1334240527" media="screen" rel="stylesheet" type="text/css" />
  <link href="/clonepin/stylesheets/errorpage.css?1334240527" media="screen" rel="stylesheet" type="text/css" />
</head>
<body>

  <div class="dialog">
    <h1>Method Not Allowed</h1>
    <p>
      The requested method GET is not allowed for the URL /candlepin/consumers/a95a92bf-bb96-4b7c-ad0f-8f6b75164dee/entitlements/dry-run.
    </p>
  </div>
</body>
</html>
Comment 5 yu zheng 2012-04-17 22:58:45 EDT
Verifying...
1.Register and autosubscribe in GUI is succeed.
2.Register by skipping auto subscription selection, then do auto subscribe is succeed.
3.Curl command of SLA dry-run could get the subscription info successfully.
# curl -k --cert /etc/pki/consumer/cert.pem --key /etc/pki/consumer/key.pem https://subscription.rhn.stage.redhat.com/subscription/consumers/c723ea9a-f96d-41e0-a051-e2f2f4b66fc8/entitlements/dry-run?service_level=PREMIUM|python -mjson.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
101  3561    0  3561    0     0   1010      0 --:--:--  0:00:03 --:--:--  1382
[
    {
        "pool": {
            "accountNumber": "1540170", 
            "activeSubscription": true, 
            "attributes": [
......

Please move this bug to ON_QA. Thanks.
Comment 6 Keqin Hong 2012-04-18 07:37:42 EDT
Move to verified as per comment 5.
Comment 8 errata-xmlrpc 2012-06-20 09:09:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.