Bug 813231 - spice-xpi.spec should Requires: virt-viewer instead of spice-client
spice-xpi.spec should Requires: virt-viewer instead of spice-client
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yuval Kashtan
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 05:44 EDT by Christophe Fergeau
Modified: 2013-08-06 00:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: spice-xpi-2.7-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: RHEL 6.3 ships an improved SPICE client called remote-viewer Change: the spice-xpi package now requires this improved client instead of requiring the spice-client package. Result: when installing or upgrading spice-xpi, the virt-viewer package (containing the remote-viewer client) is installed instead of the spice-client package. The client that spice-xpi will use can be chosen through the update-alternatives mechanism.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:48:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change Requires: (1.38 KB, patch)
2012-04-17 05:50 EDT, Christophe Fergeau
no flags Details | Diff

  None (edit)
Description Christophe Fergeau 2012-04-17 05:44:22 EDT
For 6.3 we want the default spice client started by spice-xpi to be remote-viewer, however spice-xpi.spec Requires: spice-client and not virt-viewer. This needs to be changed.
Comment 1 Christophe Fergeau 2012-04-17 05:50:50 EDT
Created attachment 577972 [details]
Change Requires:
Comment 5 Christophe Fergeau 2012-04-26 05:33:27 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: RHEL 6.3 ships an improved SPICE client called remote-viewer

Change: the spice-xpi package now requires this improved client instead of requiring the spice-client package.

Result: when installing or upgrading spice-xpi, the virt-viewer package (containing the remote-viewer client) is installed instead of the spice-client package. The client that spice-xpi will use can be chosen through the update-alternatives mechanism.
Comment 8 errata-xmlrpc 2012-06-20 10:48:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0956.html

Note You need to log in before you can comment on or make changes to this bug.