Bug 813305 - SELinux is preventing /usr/bin/updatedb from 'getattr' accesses on the blk_file /home/kalkin-back/initram/dev/mapper/st010vg-root.
SELinux is preventing /usr/bin/updatedb from 'getattr' accesses on the blk_fi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ba7069be8468c046ca0213993a9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 08:55 EDT by Bahtiar `kalkin` Gadimov
Modified: 2012-04-17 08:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 08:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bahtiar `kalkin` Gadimov 2012-04-17 08:55:59 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-5.fc16.x86_64
reason:         SELinux is preventing /usr/bin/updatedb from 'getattr' accesses on the blk_file /home/kalkin-back/initram/dev/mapper/st010vg-root.
time:           Tue 17 Apr 2012 02:55:48 PM CEST

description:
:SELinux is preventing /usr/bin/updatedb from 'getattr' accesses on the blk_file /home/kalkin-back/initram/dev/mapper/(removed)vg-root.
:
:*****  Plugin restorecon (85.9 confidence) suggests  *************************
:
:If you want to fix the label. 
:/home/kalkin-back/initram/dev/mapper/(removed)vg-root default label should be user_home_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /home/kalkin-back/initram/dev/mapper/(removed)vg-root
:
:*****  Plugin file (7.33 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin file (7.33 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin catchall (1.35 confidence) suggests  ***************************
:
:If you believe that updatedb should be allowed getattr access on the (removed)vg-root blk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep updatedb /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:locate_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:file_t:s0
:Target Objects                /home/kalkin-back/initram/dev/mapper/(removed)vg-root
:                              [ blk_file ]
:Source                        updatedb
:Source Path                   /usr/bin/updatedb
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           mlocate-0.24-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-5.fc16.x86_64 #1 SMP Tue Apr 10
:                              19:56:52 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Mon 16 Apr 2012 08:40:25 PM CEST
:Last Seen                     Tue 17 Apr 2012 03:10:11 AM CEST
:Local ID                      549a5173-b70b-4b8c-804b-7a5e2d0f3206
:
:Raw Audit Messages
:type=AVC msg=audit(1334625011.601:162): avc:  denied  { getattr } for  pid=16251 comm="updatedb" path="/home/kalkin-back/initram/dev/mapper/(removed)vg-root" dev="dm-6" ino=159806 scontext=system_u:system_r:locate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:file_t:s0 tclass=blk_file
:
:
:type=SYSCALL msg=audit(1334625011.601:162): arch=x86_64 syscall=lstat success=no exit=EACCES a0=c72409 a1=7fff67ae2040 a2=7fff67ae2040 a3=8028 items=0 ppid=16245 pid=16251 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=8 comm=updatedb exe=/usr/bin/updatedb subj=system_u:system_r:locate_t:s0-s0:c0.c1023 key=(null)
:
:Hash: updatedb,locate_t,file_t,blk_file,getattr
:
:audit2allow
:
:#============= locate_t ==============
:allow locate_t file_t:blk_file getattr;
:
:audit2allow -R
:
:#============= locate_t ==============
:allow locate_t file_t:blk_file getattr;
:
Comment 1 Bahtiar `kalkin` Gadimov 2012-04-17 08:57:40 EDT
Just noticed that's not a bug but my miss configured machine.

Note You need to log in before you can comment on or make changes to this bug.