Bug 813353 - Invalid gemspec in [/usr/lib/ruby/gems/1.8/specifications/capybara-1.1.1.gemspec]: invalid date format in specification: "2011-09-04 00:00:00.000000000Z"
Invalid gemspec in [/usr/lib/ruby/gems/1.8/specifications/capybara-1.1.1.gems...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-capybara (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Eckersberg
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 10:47 EDT by Jay Turner
Modified: 2015-01-07 19:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 15:37:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2012-04-17 10:47:06 EDT
Description of problem:
Getting the following when attempting to install rubygem-capybara

doRpmCommand-result (0): Invalid gemspec in [/usr/lib/ruby/gems/1.8/specifications/capybara-1.1.1.gemspec]: invalid date format in specification: "2011-09-04 00:00:00.000000000Z"
 rake aborted!

Version-Release number of selected component (if applicable):
1.1.1-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. 'rpm -U rubygem-capybara'
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Turner 2012-04-17 10:48:58 EDT
Marking this as proposed blocker for 1.0.0 as I do not understand the impact of this rake failing at installation time.  Not to mention that we should not be spitting out messages at package installation.
Comment 2 John Eckersberg 2012-04-17 13:01:34 EDT
rubygem-capybara-1.1.1-1.el6.noarch was built against rubygems-1.3.7; however we have since updated rubygems in cloudforms to 1.8.16.  Rebuilding with the newer rubygems fixes the malformed date in the generated gemspec file.

Here's the updated build:  https://brewweb.devel.redhat.com/buildinfo?buildID=209560
Comment 4 wes hayutin 2012-04-17 14:42:01 EDT
ugh rubygem-capybara is not even installed as part of aeolus-all..
lame..


[root@qeblade30 conf]# yum install rubygem-capybara
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package rubygem-capybara.noarch 0:1.1.1-1.el6 will be installed
--> Processing Dependency: rubygem(xpath) < 0.2 for package: rubygem-capybara-1.1.1-1.el6.noarch
--> Processing Dependency: rubygem(selenium-webdriver) < 3 for package: rubygem-capybara-1.1.1-1.el6.noarch
--> Processing Dependency: rubygem(xpath) >= 0.1.4 for package: rubygem-capybara-1.1.1-1.el6.noarch
--> Processing Dependency: rubygem(selenium-webdriver) >= 2.0 for package: rubygem-capybara-1.1.1-1.el6.noarch
--> Running transaction check
---> Package rubygem-selenium-webdriver.noarch 0:2.3.2-1.el6 will be installed
--> Processing Dependency: rubygem(childprocess) >= 0.1.9 for package: rubygem-selenium-webdriver-2.3.2-1.el6.noarch
--> Processing Dependency: rubygem(ffi) >= 1.0.7 for package: rubygem-selenium-webdriver-2.3.2-1.el6.noarch
--> Processing Dependency: rubygem(rubyzip) for package: rubygem-selenium-webdriver-2.3.2-1.el6.noarch
--> Processing Dependency: rubygem(json_pure) for package: rubygem-selenium-webdriver-2.3.2-1.el6.noarch
---> Package rubygem-xpath.noarch 0:0.1.4-1.el6 will be installed
--> Running transaction check
---> Package rubygem-childprocess.noarch 0:0.2.0-1.el6 will be installed
---> Package rubygem-ffi.x86_64 0:1.0.9-3.el6 will be installed
---> Package rubygem-json_pure.noarch 0:1.5.1-1.el6 will be installed
---> Package rubygem-rubyzip.noarch 0:0.9.4-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================
 Package                                  Arch                 Version                   Repository                         Size
=================================================================================================================================
Installing:
 rubygem-capybara                         noarch               1.1.1-1.el6               aeolus-brew-nightly               141 k
Installing for dependencies:
 rubygem-childprocess                     noarch               0.2.0-1.el6               aeolus-brew-nightly                31 k
 rubygem-ffi                              x86_64               1.0.9-3.el6               aeolus-brew-nightly               981 k
 rubygem-json_pure                        noarch               1.5.1-1.el6               aeolus-brew-nightly               708 k
 rubygem-rubyzip                          noarch               0.9.4-1.el6               aeolus-brew-nightly                97 k
 rubygem-selenium-webdriver               noarch               2.3.2-1.el6               aeolus-brew-nightly               2.8 M
 rubygem-xpath                            noarch               0.1.4-1.el6               aeolus-brew-nightly                19 k

Transaction Summary
=================================================================================================================================
Install       7 Package(s)

Total download size: 4.7 M
Installed size: 6.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): rubygem-capybara-1.1.1-1.el6.noarch.rpm                                                            | 141 kB     00:00     
(2/7): rubygem-childprocess-0.2.0-1.el6.noarch.rpm                                                        |  31 kB     00:00     
(3/7): rubygem-ffi-1.0.9-3.el6.x86_64.rpm                                                                 | 981 kB     00:00     
(4/7): rubygem-json_pure-1.5.1-1.el6.noarch.rpm                                                           | 708 kB     00:00     
(5/7): rubygem-rubyzip-0.9.4-1.el6.noarch.rpm                                                             |  97 kB     00:00     
(6/7): rubygem-selenium-webdriver-2.3.2-1.el6.noarch.rpm                                                  | 2.8 MB     00:00     
(7/7): rubygem-xpath-0.1.4-1.el6.noarch.rpm                                                               |  19 kB     00:00     
---------------------------------------------------------------------------------------------------------------------------------
Total                                                                                             14 MB/s | 4.7 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : rubygem-ffi-1.0.9-3.el6.x86_64                                                                                1/7 
  Installing : rubygem-childprocess-0.2.0-1.el6.noarch                                                                       2/7 
  Installing : rubygem-rubyzip-0.9.4-1.el6.noarch                                                                            3/7 
  Installing : rubygem-json_pure-1.5.1-1.el6.noarch                                                                          4/7 
  Installing : rubygem-selenium-webdriver-2.3.2-1.el6.noarch                                                                 5/7 
  Installing : rubygem-xpath-0.1.4-1.el6.noarch                                                                              6/7 
  Installing : rubygem-capybara-1.1.1-1.el6.noarch                                                                           7/7 
Installed products updated.

Installed:
  rubygem-capybara.noarch 0:1.1.1-1.el6                                                                                          
###############################################3

Dependency Installed:
  rubygem-childprocess.noarch 0:0.2.0-1.el6                            rubygem-ffi.x86_64 0:1.0.9-3.el6                         
  rubygem-json_pure.noarch 0:1.5.1-1.el6                               rubygem-rubyzip.noarch 0:0.9.4-1.el6                     
  rubygem-selenium-webdriver.noarch 0:2.3.2-1.el6                      rubygem-xpath.noarch 0:0.1.4-1.el6                       

[root@qeblade30 conf]# rpm -e rubygem-capybara
[root@qeblade30 conf]# yumdownloader rubygem-capybara
Loaded plugins: product-id
rubygem-capybara-1.1.1-1.el6.noarch.rpm                                                                   | 141 kB     00:00     
[root@qeblade30 conf]# rpm -U rubygem-capybara-1.1.1-1.el6.noarch.rpm
Comment 6 errata-xmlrpc 2012-05-15 15:37:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0598.html

Note You need to log in before you can comment on or make changes to this bug.