Bug 813390 - Cannot delete individual asset – the whole package inadvertently deleted
Cannot delete individual asset – the whole package inadvertently deleted
Status: CLOSED UPSTREAM
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor) (Show other bugs)
BRMS 5.3.0.GA
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tihomir Surdilovic
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 12:03 EDT by Derek Howlett
Modified: 2013-10-20 18:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 02:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Our Project Src Code. (66.05 KB, application/zip)
2012-04-17 12:03 EDT, Derek Howlett
no flags Details

  None (edit)
Description Derek Howlett 2012-04-17 12:03:16 EDT
Created attachment 578084 [details]
Our Project Src Code.

Description of problem:

Cannot delete individual asset – the whole package inadvertently deleted. So when we tried to delete a process flow (.bpmn) the whole package disappeared.



Version-Release number of selected component (if applicable):
Guvnor (BRMS 5.4.0.Beta2)

How reproducible:
DefaultPackage - Create BPMN 2.0 Asset in Repo, select it, archive it. Then from administration archive the item. Complete package is somehow deleted.

  
Actual results:
DefaultPackage is deleted

Expected results:
Only the BPM asset should be deleted.

Additional info:
o   Cannot delete individual asset – the whole package inadvertently deleted. So when we tried to delete a process flow (.bpmn) the whole package disappeared.
Comment 1 Tihomir Surdilovic 2012-04-17 12:18:21 EDT
I am unable to reproduce this. to delete an asset in guvnor you have to open this asset first. You may be archiving the entire package instead of an individual asset..that's the only explanation I can come up with now.
Comment 2 Lukáš Petrovický 2012-04-18 02:23:04 EDT
Also, this has been reported against Guvnor 5.4 Beta 2 - community releases are tracked in JIRA, http://issues.jboss.org

Note You need to log in before you can comment on or make changes to this bug.