Bug 813415 - cannot boot to updated kernel: 2.6.32-220.7.1.el6.x86_64
cannot boot to updated kernel: 2.6.32-220.7.1.el6.x86_64
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-04-17 13:31 EDT by linferna
Modified: 2013-01-10 04:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 12:21:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description linferna 2012-04-17 13:31:33 EDT
Description of problem: after yum update system cannot boot instead it hangs. Message at the console:

"Starting rhsmcertd 240 1440" ... stays there at this point for ever.


Version-Release number of selected component (if applicable):


How reproducible: By rebooting to new kernel 2.6.32-220.7.1.el6x86_64


Steps to Reproduce:
1.
2.
3.
  
Actual results: system hangs


Expected results: booting to 2.6.32-220.7.1.el6x86_64.


Additional info:

After upgrading to "2.6.32-220.7.1.el6.x86_64" system hangs during reboot at
the following line:

< Starting rhsmcertd 240 1440 >

So I have no choice other than booting back to "2.6.32-220.el6.x86_64".

Here is the grub info after the update:
<snip>
title Red Hat Enterprise Linux Workstation (2.6.32-220.7.1.el6.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-220.7.1.el6.x86_64 ro
root=UUID=a3cfe83c-84fc-4440-b72d-66d96d467fed rd_NO_LUKS  KEYBOA
RDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16
rhgb crashkernel=auto rd_NO_LVM rd_NO_
DM rhgb quiet
        initrd /initramfs-2.6.32-220.7.1.el6.x86_64.img
title Red Hat Enterprise Linux (2.6.32-220.el6.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-220.el6.x86_64 ro
root=UUID=a3cfe83c-84fc-4440-b72d-66d96d467fed rd_NO_LUKS  KEYBOARDTY
PE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16
rhgb crashkernel=auto rd_NO_LVM rd_NO_DM r
hgb quiet
        initrd /initramfs-2.6.32-220.el6.x86_64.img
<snip>

Here is the 'tail /var/log/rhsm/rhsmcertd.log' output:
Mon Apr 16 15:09:33 2012: started: interval = 1440 minutes
Mon Apr 16 15:09:33 2012: started: interval = 240 minutes
Mon Apr 16 15:09:35 2012: certificates updated
Mon Apr 16 15:09:35 2012: certificates updated
Mon Apr 16 15:14:27 2012: started: interval = 1440 minutes
Mon Apr 16 15:14:27 2012: started: interval = 240 minutes
Mon Apr 16 15:14:30 2012: certificates updated
Mon Apr 16 15:14:30 2012: certificates updated
Mon Apr 16 19:14:29 2012: certificates updated
Mon Apr 16 23:14:30 2012: certificates updated

It appears this problem has been fixed but I still experience the original
problem. Appreciate a feedback.
Comment 2 linferna 2012-04-17 13:35:53 EDT
Since I get hang up during reboot (kernel 2.6.32-220.7.1.el6.x86_64), I tried
stopping (chkconfig rhsmcertd off). Then the system hangs up at RHN Daemon
(Starting Red Hat Network Daemon  [OK] ). 

However, I was able to boot back to 2.6.32-220.el6.x86_64 kernel from grub,
while my 'rhsmcertd off' state. I am surprised why this issue hasn't reopen.
Thanks for any feedback.
Comment 3 linferna 2012-04-18 20:53:13 EDT
Today I upgraded to "2.6.32-220.13.1.el6.x86_64" but the issue is still the same, it still hangs at "Starting rhsmcertd 240 1440" never boots to the OS.

Thanks and Waiting for feedback.
Comment 4 linferna 2012-04-20 10:59:05 EDT
Definitely this is not a kernel bug as I thought of. I had built the NVidia kernel module for my Nvidial video card. I had to blacklist the nouveau, RH native Nvidia module. Since I upgraded the workstation(kernel upgrade), manufacturer Nvidia wouldn't work. Also, the RH native nouveau wouldn't load due to the blacklisting. 

As a remedy I had to de-activate the blacklisting of nouveau module then the system booted to the new kernel. I also had to rename the xorg.conf file.
Comment 5 Bryan Kearney 2012-08-13 21:43:53 EDT
is this related to subscription-manager?
Comment 6 linferna 2012-08-13 23:22:32 EDT
(In reply to comment #5)
> is this related to subscription-manager?

Yes it is related to rhsmcertd. Nouveau needed to be blacklisted to install Nvidia driver. There is lot of info in the Nvidia forums.
Comment 7 Bryan Kearney 2012-10-26 16:10:05 EDT
I am running fine on 2.6.32-279.11.1.el6.x86_64. Can you let me know how to reproduce this.
Comment 8 Bryan Kearney 2012-11-12 12:21:31 EST
I have run a 6.2 to 6.3 upgrade, and can not reproduce this. Closing.

Note You need to log in before you can comment on or make changes to this bug.