Bug 813640 - virt-p2v can not discover disks of physical host with Adaptec aacraid driver
virt-p2v can not discover disks of physical host with Adaptec aacraid driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Matthew Booth
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 01:45 EDT by tingting zheng
Modified: 2012-06-20 11:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: rubygem-virt-p2v-0.8.6-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:09:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of virt-p2v client UI (30.36 KB, image/png)
2012-04-18 01:45 EDT, tingting zheng
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0965 normal SHIPPED_LIVE new package: virt-p2v 2012-06-19 17:12:05 EDT

  None (edit)
Description tingting zheng 2012-04-18 01:45:08 EDT
Created attachment 578237 [details]
screenshot of virt-p2v client UI

Description of Problem:
virt-p2v can not discover disks of physical host with Adaptec aacraid driver

Version-Release number of selected component:
virt-v2v-0.8.7-4.el6.x86_64
rubygem-virt-p2v-0.8.6-2.el6

How reproducible:
Always

Step to Reproduce:
1.Installed rhel6 on machines with Adaptec aacraid driver,which is installed on /dev/sda1.
# fdisk -l
Disk /dev/sda: 146.6 GB, 146580439040 bytes
255 heads, 63 sectors/track, 17820 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0008c651

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1306    10485760   83  Linux

# lsmod |grep aacraid
aacraid                75664  1 

# lspci|grep RAID
01:00.0 RAID bus controller: Adaptec AAC-RAID (Rocket) (rev 02)

2.Use virt-p2v to boot,there is no storage(like sda) showed under Fixed storage tab.

Actual Results:
There is no storage(like sda) showed under Fixed storage tab,attached the screenshot.

Expected Results:
The storage should be listed there.

Additional info:
Comment 6 tingting zheng 2012-04-26 01:52:32 EDT
Verified the bug with rubygem-virt-p2v-0.8.6-3.el6.
Boot physical machines with Adaptec aacraid driver from virt-p2v iso,the storage sda showed under Fixed storage tab.So change the status of the bug to VERIFIED.
Comment 7 errata-xmlrpc 2012-06-20 11:09:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0965.html

Note You need to log in before you can comment on or make changes to this bug.