Bug 813664 - "targetcli" don't check daemon status but complain about no WWPN found.
"targetcli" don't check daemon status but complain about no WWPN found.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils (Show other bugs)
6.3
All All
unspecified Severity high
: rc
: ---
Assigned To: Andy Grover
Gris Ge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 03:23 EDT by Gris Ge
Modified: 2012-06-20 09:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:50:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-04-18 03:23:00 EDT
Description of problem:

When try to create fcoe target via this command in targetcli:
===
/> /tcm_fc/ create 20:00:00:1b:21:59:12:36
Invalid wwn 20:00:00:1b:21:59:12:36 for tcm_fc fabric 
===

The root cause if this is just fcoe-target daemon not start.

Please check fcoe-target daemon or kernel module's existence before complain about no WWPN found.

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb10-3.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Execute targetcli without fcoe-target daemon started.
2. execute this command (replace the WWPN with correct one)
===
/tcm_fc/ create 20:00:00:1b:21:59:12:36
===
3.
  
Actual results:
Complained about no WWPN found.

Expected results:
Provide correct info about error.

Additional info:
Miss lead error message could waste too much time of user/customer or cause unnecessary support call.

Requesting blocker for 6.3
Comment 2 Gris Ge 2012-05-22 02:30:58 EDT
fcoe-target-utils-2.0rc1.fb10-5.el6.noarch will check daemon status when execute targetcli.

VERIFY.
Comment 4 errata-xmlrpc 2012-06-20 09:50:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0854.html

Note You need to log in before you can comment on or make changes to this bug.