Bug 813780 - Conditional jump or move depends on uninitialised value in expand_dynamic_string_token (x86_64 only)
Conditional jump or move depends on uninitialised value in expand_dynamic_str...
Status: CLOSED DUPLICATE of bug 801841
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: valgrind (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks: 839713 813478 813481
  Show dependency treegraph
 
Reported: 2012-04-18 08:24 EDT by Caolan McNamara
Modified: 2012-07-12 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 06:53:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2012-04-18 08:24:58 EDT
Description of problem:

==9316== Conditional jump or move depends on uninitialised value(s)
==9316==    at 0x4017D96: index (in /usr/lib64/ld-2.15.so)
==9316==    by 0x40079E7: expand_dynamic_string_token (in /usr/lib64/ld-2.15.so)
==9316==    by 0x400827C: _dl_map_object (in /usr/lib64/ld-2.15.so)
==9316==    by 0x400171D: map_doit (in /usr/lib64/ld-2.15.so)
==9316==    by 0x400ECB5: _dl_catch_error (in /usr/lib64/ld-2.15.so)
==9316==    by 0x4000EE3: do_preload (in /usr/lib64/ld-2.15.so)
==9316==    by 0x40040B4: dl_main (in /usr/lib64/ld-2.15.so)
==9316==    by 0x40151DA: _dl_sysdep_start (in /usr/lib64/ld-2.15.so)
==9316==    by 0x4004EF1: _dl_start (in /usr/lib64/ld-2.15.so)
==9316==    by 0x4001537: ??? (in /usr/lib64/ld-2.15.so)
==9316==    by 0x2: ???
==9316==    by 0x7FF000B26: ???

Version-Release number of selected component (if applicable):
1:valgrind-3.7.0-2.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
fedpkg build hyphen
  
Additional info:
looks exactly the same as https://bugzilla.redhat.com/show_bug.cgi?id=676785
Comment 1 Miroslav Franc 2012-04-23 05:53:09 EDT
I believe this is already tracked in Bug 801841.
Comment 2 Caolan McNamara 2012-04-23 06:53:06 EDT

*** This bug has been marked as a duplicate of bug 801841 ***

Note You need to log in before you can comment on or make changes to this bug.