Bug 813938 - impossible to automount SD card after kernel update
impossible to automount SD card after kernel update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 15:53 EDT by Pablo Rodríguez
Modified: 2013-02-13 20:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 20:28:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo Rodríguez 2012-04-18 15:53:24 EDT
Hi there,

after updating today to kernel-3.3.1-5.fc16.i686 (with yum), I'm afraid that SD cards aren't auto-mounted after inserted.

This worked with previous kernel-3.3.1-3.fc16.i686.

Just in case it helps, here is my SD card slot info:

03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
03:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)

Many thanks for your help,


Pablo
Comment 1 Josh Boyer 2012-04-18 16:12:56 EDT
There's really nothing between 3.3.1-3 and 3.3.1-5 that should impact that at all.  Only some media drivers were updated.

Was anything else updated at the same time?  Your yum log should show this.
Comment 2 Pablo Rodríguez 2012-04-18 16:37:43 EDT
(In reply to comment #1)
> There's really nothing between 3.3.1-3 and 3.3.1-5 that should impact that at
> all.  Only some media drivers were updated.
> 
> Was anything else updated at the same time?  Your yum log should show this.

Apr 18 21:18:51 Updated: wine-core-1.5.1-1.fc16.i686
Apr 18 21:18:51 Updated: wine-common-1.5.1-1.fc16.noarch
Apr 18 21:18:52 Updated: wine-small-fonts-1.5.1-1.fc16.noarch
Apr 18 21:18:52 Updated: wine-systemd-1.5.1-1.fc16.noarch
Apr 18 21:18:54 Updated: wine-desktop-1.5.1-1.fc16.noarch
Apr 18 21:18:55 Updated: wine-courier-fonts-1.5.1-1.fc16.noarch
Apr 18 21:18:56 Updated: wine-ms-sans-serif-fonts-1.5.1-1.fc16.noarch
Apr 18 21:18:56 Updated: wine-marlett-fonts-1.5.1-1.fc16.noarch
Apr 18 21:18:56 Updated: wine-tahoma-fonts-1.5.1-1.fc16.noarch
Apr 18 21:18:57 Updated: wine-symbol-fonts-1.5.1-1.fc16.noarch
Apr 18 21:18:57 Updated: wine-system-fonts-1.5.1-1.fc16.noarch
Apr 18 21:18:57 Updated: wine-fonts-1.5.1-1.fc16.noarch
Apr 18 21:19:43 Updated: wine-debuginfo-1.5.1-1.fc16.i686
Apr 18 21:19:47 Updated: tzdata-java-2012c-1.fc16.noarch
Apr 18 21:19:54 Updated: tzdata-2012c-1.fc16.noarch
Apr 18 21:19:55 Updated: wine-sysvinit-1.5.1-1.fc16.noarch
Apr 18 21:19:55 Updated: coreutils-libs-8.12-7.fc16.i686
Apr 18 21:20:00 Updated: coreutils-8.12-7.fc16.i686
Apr 18 21:20:00 Updated: audit-libs-2.2.1-1.fc16.i686
Apr 18 21:20:00 Installed: 1:libwbclient-3.6.4-82.fc16.i686
Apr 18 21:20:01 Updated: 1:cups-libs-1.5.2-8.1.fc16.i686
Apr 18 21:20:02 Updated: wine-openal-1.5.1-1.fc16.i686
Apr 18 21:20:02 Updated: wine-cms-1.5.1-1.fc16.i686
Apr 18 21:20:03 Updated: wine-twain-1.5.1-1.fc16.i686
Apr 18 21:20:03 Updated: wine-ldap-1.5.1-1.fc16.i686
Apr 18 21:20:04 Updated: wine-alsa-1.5.1-1.fc16.i686
Apr 18 21:20:04 Updated: wine-pulseaudio-1.5.1-1.fc16.i686
Apr 18 21:20:04 Updated: wine-wow-1.5.1-1.fc16.i686
Apr 18 21:20:05 Updated: wine-capi-1.5.1-1.fc16.i686
Apr 18 21:20:05 Updated: wine-1.5.1-1.fc16.i686
Apr 18 21:20:12 Updated: 1:cups-1.5.2-8.1.fc16.i686
Apr 18 21:20:14 Updated: meld-1.5.4-1.fc16.noarch
Apr 18 21:20:15 Updated: 1:samba-winbind-clients-3.6.4-82.fc16.i686
Apr 18 21:20:16 Updated: 1:libsmbclient-3.6.4-82.fc16.i686
Apr 18 21:20:17 Updated: audit-2.2.1-1.fc16.i686
Apr 18 21:20:17 Updated: audit-libs-python-2.2.1-1.fc16.i686
Apr 18 21:20:30 Installed: kernel-3.3.1-5.fc16.i686
Apr 18 21:20:36 Updated: wine-devel-1.5.1-1.fc16.i686
Apr 18 21:20:37 Updated: flash-plugin-11.2.202.233-release.i386
Apr 18 21:20:39 Updated: mysql-libs-5.5.22-1.fc16.i686
Apr 18 21:20:41 Updated: kernel-tools-3.3.1-5.fc16.i686
Apr 18 21:20:44 Updated: llvm-libs-2.9-10.fc16.i686

Could it be that kernel-tools is the culprit?

Thanks for your help,


Pablo
Comment 3 Pablo Rodríguez 2012-04-18 17:11:00 EDT
After loading the system with kernel-3.3.1-3, card was auto-mounted when inserted, I loaded the system with kernel-3.3.1-5 and it worked fine (although it didn't work before).

So I'm closing the bug as errata (my guess as the closest match to invalid).

Sorry for the noise and many thanks for your help,


Pablo
Comment 4 Pablo Rodríguez 2012-04-21 16:46:09 EDT
I'm afraid I have the same error after upgrading the kernel again.

Apr 21 11:46:51 Updated: nspr-4.9-2.fc16.i686
Apr 21 11:46:52 Updated: libquvi-scripts-0.4.4-1.fc16.noarch
Apr 21 11:46:52 Updated: nss-util-3.13.4-2.fc16.i686
Apr 21 11:46:53 Updated: freetype-2.4.6-5.fc16.i686
Apr 21 11:46:54 Updated: PackageKit-yum-0.6.22-1.fc16.i686
Apr 21 11:46:57 Updated: PackageKit-0.6.22-1.fc16.i686
Apr 21 11:46:58 Updated: PackageKit-glib-0.6.22-1.fc16.i686
Apr 21 11:46:58 Updated: nss-softokn-freebl-3.13.4-1.fc16.i686
Apr 21 11:46:59 Updated: nss-softokn-3.13.4-1.fc16.i686
Apr 21 11:46:59 Updated: nss-sysinit-3.13.4-2.fc16.i686
Apr 21 11:47:00 Updated: nss-3.13.4-2.fc16.i686
Apr 21 11:47:02 Updated: 1:NetworkManager-glib-0.9.4-2.git20120403.fc16.i686
Apr 21 11:47:02 Updated: 1:NetworkManager-gtk-0.9.4-2.git20120403.fc16.i686
Apr 21 11:47:05 Updated: 1:NetworkManager-0.9.4-2.git20120403.fc16.i686
Apr 21 11:47:08 Updated: 1:qt-4.8.1-5.fc16.i686
Apr 21 11:47:08 Updated: PackageKit-yum-plugin-0.6.22-1.fc16.i686
Apr 21 11:47:09 Updated: freetype-devel-2.4.6-5.fc16.i686
Apr 21 11:47:15 Updated: 1:qt-x11-4.8.1-5.fc16.i686
Apr 21 11:47:16 Updated: 1:NetworkManager-gnome-0.9.4-2.git20120403.fc16.i686
Apr 21 11:47:17 Updated: openldap-2.4.26-7.fc16.i686
Apr 21 11:47:17 Updated: PackageKit-device-rebind-0.6.22-1.fc16.i686
Apr 21 11:47:18 Updated: PackageKit-gstreamer-plugin-0.6.22-1.fc16.i686
Apr 21 11:47:18 Updated: PackageKit-gtk-module-0.6.22-1.fc16.i686
Apr 21 11:47:18 Updated: PackageKit-command-not-found-0.6.22-1.fc16.i686
Apr 21 11:47:19 Updated: PackageKit-gtk3-module-0.6.22-1.fc16.i686
Apr 21 11:47:23 Updated: shotwell-0.10.1-4.fc16.i686
Apr 21 11:47:23 Updated: libquvi-0.4.1-1.fc16.i686
Apr 21 11:47:37 Installed: kernel-3.3.2-1.fc16.i686
Apr 21 11:47:38 Updated: kernel-tools-3.3.2-1.fc16.i686
Apr 21 11:47:39 Updated: rp-pppoe-3.10-12.fc16.i686

I don't know what is wrong here, but the SD card isn't automounted.

BTW, since I can only reopen the issue as assigned, could you reopen the bug for me?

Thanks for your help,


Pablo
Comment 5 Pablo Rodríguez 2012-04-28 16:56:21 EDT
I reopen the bug, since there is no automount only in SD cards with latest kernel updates.

I have a weird workaround, which is to suspend and awake the system again, but fixing the issue properly would be better.

Many thanks for your help,


Pablo
Comment 6 Dave Jones 2012-10-23 11:39:08 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 7 Pablo Rodríguez 2012-10-24 15:04:49 EDT
I'm afraid that the bug is still there with the new kernel.
Comment 8 Pablo Rodríguez 2013-01-12 18:54:14 EST
Here is the dmesg info when I insert them and it doesn't get recognized:

[ 1064.129100] r852: detected xD writeable card in slot
[ 1064.440036] No NAND device found
[ 1065.432483] mmc0: Got command interrupt 0x00030000 even though no command ope
ration was in progress.
[ 1065.434594] mmc0: Got command interrupt 0x00030000 even though no command ope
ration was in progress.

But if I suspend and restart again, I get it:

[ 1123.177224] mmc0: new high speed SDHC card at address e624
[ 1123.178515] mmcblk0: mmc0:e624 SU32G 29.7 GiB 
[ 1123.190919]  mmcblk0: p1

Could you please help me with this issue?

Many thanks,


Pablo
Comment 9 Fedora End Of Life 2013-01-16 17:58:43 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora End Of Life 2013-02-13 20:28:50 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.