Bug 813980 - pmac ide driver not compiled
pmac ide driver not compiled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
ppc Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 18:52 EDT by Ingvar Hagelund
Modified: 2012-04-19 17:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 17:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2012-04-18 18:52:38 EDT
Description of problem:
The old ide pmac driver is no longer compiled as a module to the kernel

Version-Release number of selected component (if applicable):
kernel-3.3.1-5.fc17.ppc

How reproducible:
Always

Steps to Reproduce:
1. Boot some old 32bit ppc macintosh, like the pismo iBook
2. Watch dracut die since it can't find any rootfs

  
Actual results:
pmac ide module missing

Expected results:
pmac ide module included

Additional info:
While the old pmac driver does not support libata, it is still usable. dracut will see the disk if the driver forced loaded at boot time, for example using a boot argument like rdinsmodpost=pmac
Comment 1 Josh Boyer 2012-04-18 20:01:28 EDT
This was done intentionally under bug 810579.

I very seriously doubt Fedora is going to continue to support any G3 Macs.  At this point you might be better off building your own kernel, or at least building the pmac module separately.

I'll let Karsten decide, since the pmac module seems to break newer G4/G5 Macs.
Comment 2 Karsten Hopp 2012-04-19 06:20:49 EDT
This is a different problem as the pata_macio driver can handle all the devices that ide_pmac used to handle, it just does it with libsata and thus the device names will change.

Can you check if dracut has included the pata_macio driver in the initrd ?

Something like
lsinitrd /boot/initramfs-3.3.1-5.fc17.ppc64.img | grep pata_mac
should work

You also need to check if /etc/fstab and /etc/yaboot.conf still reference /dev/hdX instead of /dev/sdX. 


@Josh: No, we certainly don't want to have ide_pmac back.
Comment 3 Ingvar Hagelund 2012-04-19 17:23:04 EDT
On this hardware, I have to build a custom initramfs, but it boots fine with pata_macio. Thanks.

I closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.