Bug 814030 - SELinux is preventing /usr/libexec/mysqld from 'getattr' accesses on the directory /home/mysql/mysql/wikidb.
SELinux is preventing /usr/libexec/mysqld from 'getattr' accesses on the dire...
Status: CLOSED DUPLICATE of bug 814001
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:58c442f4fed39f6669d69881868...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 00:10 EDT by Adrin Jalali
Modified: 2012-04-20 10:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 10:53:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2012-04-19 00:10:03 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-5.fc16.x86_64
reason:         SELinux is preventing /usr/libexec/mysqld from 'getattr' accesses on the directory /home/mysql/mysql/wikidb.
time:           Wed 18 Apr 2012 09:09:56 PM PDT

description:
:SELinux is preventing /usr/libexec/mysqld from 'getattr' accesses on the directory /home/mysql/mysql/wikidb.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mysqld should be allowed getattr access on the wikidb directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mysqld /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:mysqld_t:s0
:Target Context                system_u:object_r:user_home_t:s0
:Target Objects                /home/mysql/mysql/wikidb [ dir ]
:Source                        mysqld
:Source Path                   /usr/libexec/mysqld
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           mysql-server-5.5.22-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-5.fc16.x86_64 #1 SMP Tue
:                              Apr 10 19:56:52 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Wed 18 Apr 2012 07:50:11 PM PDT
:Last Seen                     Wed 18 Apr 2012 09:05:17 PM PDT
:Local ID                      b7e7fc0b-db9a-4658-9466-52831e46e822
:
:Raw Audit Messages
:type=AVC msg=audit(1334808317.794:226): avc:  denied  { getattr } for  pid=13910 comm="mysqld" path="/home/mysql/mysql/wikidb" dev="sdb4" ino=34078957 scontext=system_u:system_r:mysqld_t:s0 tcontext=system_u:object_r:user_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1334808317.794:226): arch=x86_64 syscall=lstat success=yes exit=0 a0=7f4274052140 a1=7f4274052070 a2=7f4274052070 a3=fffffff8 items=0 ppid=1 pid=13910 auid=4294967295 uid=27 gid=27 euid=27 suid=27 fsuid=27 egid=27 sgid=27 fsgid=27 tty=(none) ses=4294967295 comm=mysqld exe=/usr/libexec/mysqld subj=system_u:system_r:mysqld_t:s0 key=(null)
:
:Hash: mysqld,mysqld_t,user_home_t,dir,getattr
:
:audit2allow
:
:#============= mysqld_t ==============
:allow mysqld_t user_home_t:dir getattr;
:
:audit2allow -R
:
:#============= mysqld_t ==============
:allow mysqld_t user_home_t:dir getattr;
:
Comment 1 Daniel Walsh 2012-04-20 10:53:58 EDT

*** This bug has been marked as a duplicate of bug 814001 ***

Note You need to log in before you can comment on or make changes to this bug.