Bug 814075 - Seam: Invalid dependencies in Seam distribution
Seam: Invalid dependencies in Seam distribution
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.0.0.ER4,2.0.0.ER7
Unspecified Unspecified
high Severity high
: ---
: 2.0.0.ER8
Assigned To: Marek Novotny
Karel Piwko
Seam2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 03:47 EDT by Karel Piwko
Modified: 2012-06-22 03:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Seam 2.3.0.Beta1-redhat-1
Last Closed: 2012-06-22 03:32:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Piwko 2012-04-19 03:47:25 EDT
Following dependencies are not available in nor EAP zip, WFK zip, EAP plugins or Maven Central:

cat bar | sed 's/^.*Failure to find \([^ ]*\) in .*$/\* \1/' | sort -u
* dom4j:dom4j:jar:1.6.1-brew
* javax.inject:javax.inject:jar:1.0-PFD-1
* org.apache.httpcomponents:httpcomponents-client:pom:4.1.3-redhat-1
* org.apache.maven.surefire:surefire:pom:2.4.3-JBOSS
* org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1
* org.jboss.el:jboss-el:jar:1.0_02.CR6
* org.richfaces:root:pom:3.3.1.SP3
* xmlunit:xmlunit:jar:1.3_redhat_1

Log:

[ERROR] Failed to execute goal on project jboss-seam-ioc: Could not resolve dependencies for project org.jboss.seam:jboss-seam-ioc:jar:2.3.0.Beta1-redhat-1: The following artifacts could not be resolved: org.jboss.el:jboss-el:jar:1.0_02.CR6, org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam-mail: Could not resolve dependencies for project org.jboss.seam:jboss-seam-mail:jar:2.3.0.Beta1-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam-pdf: Could not resolve dependencies for project org.jboss.seam:jboss-seam-pdf:jar:2.3.0.Beta1-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam-resteasy: Could not resolve dependencies for project org.jboss.seam:jboss-seam-resteasy:jar:2.3.0.Beta1-redhat-1: The following artifacts could not be resolved: org.jboss.el:jboss-el:jar:1.0_02.CR6, org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam-flex: Could not resolve dependencies for project org.jboss.seam:jboss-seam-flex:jar:2.3.0.Beta1-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam: Could not resolve dependencies for project org.jboss.seam:jboss-seam:ejb:2.3.0.Beta1-redhat-1: The following artifacts could not be resolved: org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1, org.hibernate:hibernate-entitymanager:jar:4.1.1.Final-redhat-1, dom4j:dom4j:jar:1.6.1-brew, jgroups:jgroups:jar:2.6.20.Final, org.drools:drools-core:jar:5.2.1.BRMS, org.drools:drools-compiler:jar:5.2.1.BRMS, org.drools:drools-templates:jar:5.2.1.BRMS, org.drools:drools-decisiontables:jar:5.2.1.BRMS, org.jbpm.jbpm3:jbpm-jpdl:jar:3.2.11.SP1, org.jboss.el:jboss-el:jar:1.0_02.CR6, org.opensymphony.quartz:quartz:jar:1.6.5, oswego-concurrent:concurrent:jar:1.3.4: Failure to find org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam-debug: Could not resolve dependencies for project org.jboss.seam:jboss-seam-debug:jar:2.3.0.Beta1-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam-excel: Could not resolve dependencies for project org.jboss.seam:jboss-seam-excel:jar:2.3.0.Beta1-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jboss-seam-remoting: Could not resolve dependencies for project org.jboss.seam:jboss-seam-remoting:jar:2.3.0.Beta1-redhat-1: The following artifacts could not be resolved: dom4j:dom4j:jar:1.6.1-brew, org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1, org.jboss.el:jboss-el:jar:1.0_02.CR6: Failure to find dom4j:dom4j:jar:1.6.1-brew in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] [FATAL] Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10
[ERROR] Failed to execute goal on project jsf-test-stage: Could not resolve dependencies for project org.jboss.test-jsf:jsf-test-stage:jar:1.1.2-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] Failed to execute goal on project jsf-test-jetty: Could not resolve dependencies for project org.jboss.test-jsf:jsf-test-jetty:jar:1.1.2-redhat-1: Failure to find org.jboss.el:jboss-el:jar:1.0_02.CR6 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR] [FATAL] Non-resolvable parent POM: Failure to find org.apache.maven.surefire:surefire:pom:2.4.3-JBOSS in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ line 22, column 11
[ERROR] Failed to execute goal on project richfaces-core-impl: Could not resolve dependencies for project org.richfaces.core:richfaces-core-impl:jar:4.2.0.Final-redhat-1: Failed to collect dependencies for [org.richfaces.core:richfaces-core-api:jar:4.2.0.Final-redhat-1 (compile), net.sourceforge.cssparser:cssparser:jar:[0.9.5,0.9.5-redhat-1] (compile), com.google.guava:guava:jar:11.0.2-redhat-1 (compile), org.jboss.spec.javax.el:jboss-el-api_2.2_spec:jar:1.0.0.Final-redhat-1 (provided), org.jboss.spec.javax.servlet:jboss-servlet-api_3.0_spec:jar:1.0.0.Final-redhat-1 (provided), org.jboss.spec.javax.servlet.jsp:jboss-jsp-api_2.2_spec:jar:1.0.0.Final-redhat-1 (provided), org.jboss.spec.javax.servlet.jstl:jboss-jstl-api_1.2_spec:jar:1.0.2.Final-redhat-1 (provided), javax.enterprise:cdi-api:jar:1.0-SP4-redhat-1 (provided), org.jboss.spec.javax.jms:jboss-jms-api_1.1_spec:jar:[1.0.1.Final,1.0.1.Final-redhat-1] (compile?), org.jboss.cache:jbosscache-core:jar:3.2.8.GA (compile?), net.sf.ehcache:ehcache:jar:1.6.0 (compile?), opensymphony:oscache:jar:2.3 (compile?), org.atmosphere:atmosphere-runtime:jar:0.8.4 (compile?), org.jboss.test-jsf:htmlunit-client:jar:1.1.2-redhat-1 (test), org.apache.httpcomponents:httpmime:jar:[4.1.3,4.1.3-redhat-1] (test), org.apache.james:apache-mime4j:jar:[0.6,0.6-redhat-1] (compile), org.apache.httpcomponents:httpcore:jar:[4.1.4,4.1.4-redhat-1] (test), org.jboss.test-jsf:jsf-mock:jar:1.1.2-redhat-1 (test), org.easymock:easymock:jar:2.5.2 (test), org.easymock:easymockclassextension:jar:2.5.2 (test), cglib:cglib-nodep:jar:[2.2.2,2.2.2-redhat-1] (test), org.jboss.test-jsf:jsf-mockito:jar:1.1.2-redhat-1 (test), org.mockito:mockito-all:jar:1.8.5 (test), commons-codec:commons-codec:jar:[1.4,1.4-redhat-1] (test), org.jboss.spec.javax.faces:jboss-jsf-api_2.1_spec:jar:2.0.1.Final-redhat-1 (compile), com.sun.faces:jsf-impl:jar:2.1.7-redhat-1 (test)]: Failed to read artifact descriptor for org.apache.httpcomponents:httpclient:jar:4.1.3-redhat-1: Failure to find org.apache.httpcomponents:httpcomponents-client:pom:4.1.3-redhat-1 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR] Failed to execute goal on project generator: Could not resolve dependencies for project org.richfaces.cdk:generator:jar:4.2.0.Final-redhat-1: The following artifacts could not be resolved: javax.inject:javax.inject:jar:1.0-PFD-1, javax.xml.bind:jaxb-api:jar:2.2.4-redhat-1, org.jboss.el:jboss-el:jar:1.0_02.CR6, xerces:xercesImpl:jar:2.9.1-patch-01, com.sun.xsom:xsom:jar:20110101-redhat-1, com.google.inject:guice:jar:3.0-redhat-1, com.google.inject.extensions:guice-assistedinject:jar:3.0-redhat-1, com.google.inject.extensions:guice-multibindings:jar:3.0-redhat-1, xmlunit:xmlunit:jar:1.3_redhat_1: Failure to find javax.inject:javax.inject:jar:1.0-PFD-1 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR] Failed to execute goal on project xinclude: Could not resolve dependencies for project org.richfaces.cdk:xinclude:jar:4.2.0.Final-redhat-1: The following artifacts could not be resolved: xmlunit:xmlunit:jar:1.3_redhat_1, javax.inject:javax.inject:jar:1.0-PFD-1: Failure to find xmlunit:xmlunit:jar:1.3_redhat_1 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR]     Non-resolvable parent POM: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced and 'parent.relativePath' points at wrong local POM @ line 2, column 11 -> [Help 2]
[ERROR] Failed to execute goal on project maven-cdk-plugin: Could not resolve dependencies for project org.richfaces.cdk:maven-cdk-plugin:maven-plugin:4.2.0.Final-redhat-1: The following artifacts could not be resolved: javax.inject:javax.inject:jar:1.0-PFD-1, javax.xml.bind:jaxb-api:jar:2.2.4-redhat-1, org.jboss.el:jboss-el:jar:1.0_02.CR6, xerces:xercesImpl:jar:2.9.1-patch-01, com.sun.xsom:xsom:jar:20110101-redhat-1, com.google.inject:guice:jar:3.0-redhat-1, com.google.inject.extensions:guice-assistedinject:jar:3.0-redhat-1, com.google.inject.extensions:guice-multibindings:jar:3.0-redhat-1, xmlunit:xmlunit:jar:1.3_redhat_1: Failure to find javax.inject:javax.inject:jar:1.0-PFD-1 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR]     Non-resolvable parent POM for org.richfaces:cdk:3.3.1.SP3: Failure to find org.richfaces:root:pom:3.3.1.SP3 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced @ org.richfaces:cdk:3.3.1.SP3, /home/jenkins/workspace/wfk-2.0-maven-repository-verify/maven-bootstrap/../.repository/org/richfaces/cdk/3.3.1.SP3/cdk-3.3.1.SP3.pom, line 2, column 10 -> [Help 2]
[ERROR] Failed to execute goal on project commons: Could not resolve dependencies for project org.richfaces.cdk:commons:jar:4.2.0.Final-redhat-1: Failure to find javax.inject:javax.inject:jar:1.0-PFD-1 in http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ was cached in the local repository, resolution will not be reattempted until the update interval of eap6-plugin-repository has elapsed or updates are forced -> [Help 1]
Comment 1 Karel Piwko 2012-04-19 03:55:20 EDT
Additional list of missing files:

cat foo | grep 'The following artifacts could not be resolved' | sed 's/^.* resolved:\(.*\): \(Failure\|Could\).*$/\1/' | tr ', ' '\n*'
*org.jboss.el:jboss-el:jar:1.0_02.CR6
*dom4j:dom4j:jar:1.6.1-brew
*org.jboss.seam:jboss-seam-gen:zip:distribution:2.3.0.Beta1-redhat-1
*org.jboss.el:jboss-el:jar:1.0_02.CR6
*org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1
*org.jboss.el:jboss-el:jar:1.0_02.CR6
*org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1
*org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1
*org.hibernate:hibernate-entitymanager:jar:4.1.1.Final-redhat-1
*dom4j:dom4j:jar:1.6.1-brew
*jgroups:jgroups:jar:2.6.20.Final
*org.drools:drools-core:jar:5.2.1.BRMS
*org.drools:drools-compiler:jar:5.2.1.BRMS
*org.drools:drools-templates:jar:5.2.1.BRMS
*org.drools:drools-decisiontables:jar:5.2.1.BRMS
*org.jbpm.jbpm3:jbpm-jpdl:jar:3.2.11.SP1
*org.jboss.el:jboss-el:jar:1.0_02.CR6
*org.opensymphony.quartz:quartz:jar:1.6.5
*oswego-concurrent:concurrent:jar:1.3.4
*dom4j:dom4j:jar:1.6.1-brew
*org.hibernate:hibernate-core:jar:4.1.1.Final-redhat-1
*org.jboss.el:jboss-el:jar:1.0_02.CR6
*org.jboss.kernel:jboss-dependency:jar:2.2.0.SP2
*org.jboss.kernel:jboss-kernel:jar:2.2.0.SP2
*javax.inject:javax.inject:jar:1.0-PFD-1
*javax.xml.bind:jaxb-api:jar:2.2.4-redhat-1
*org.jboss.el:jboss-el:jar:1.0_02.CR6
*xerces:xercesImpl:jar:2.9.1-patch-01
*com.sun.xsom:xsom:jar:20110101-redhat-1
*com.google.inject:guice:jar:3.0-redhat-1
*com.google.inject.extensions:guice-assistedinject:jar:3.0-redhat-1
*com.google.inject.extensions:guice-multibindings:jar:3.0-redhat-1
*xmlunit:xmlunit:jar:1.3_redhat_1
*xmlunit:xmlunit:jar:1.3_redhat_1
*javax.inject:javax.inject:jar:1.0-PFD-1
*javax.inject:javax.inject:jar:1.0-PFD-1
*javax.xml.bind:jaxb-api:jar:2.2.4-redhat-1
*org.jboss.el:jboss-el:jar:1.0_02.CR6
*xerces:xercesImpl:jar:2.9.1-patch-01
*com.sun.xsom:xsom:jar:20110101-redhat-1
*com.google.inject:guice:jar:3.0-redhat-1
*com.google.inject.extensions:guice-assistedinject:jar:3.0-redhat-1
*com.google.inject.extensions:guice-multibindings:jar:3.0-redhat-1
*xmlunit:xmlunit:jar:1.3_redhat_1
Comment 2 Karel Piwko 2012-05-10 04:49:27 EDT
Bumped version to ER6.
Comment 3 Marek Novotny 2012-05-20 04:32:26 EDT
Target it ER7 as 2.3.0.Beta2 will be aimed to ER7
Comment 4 Marek Novotny 2012-05-31 08:18:04 EDT
Please check the list with the latest ER7
Comment 5 Karel Piwko 2012-05-31 12:17:21 EDT
List of transitive dependencies missing in Seam 2.3 Beta2 in WFK ER7:


* dom4j:dom4j:jar:1.6.1-brew
     in (org.jboss.seam:distribution:pom:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-seam-ioc:jar:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-seam-remoting:jar:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-seam-resteasy:jar:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-seam-ui:jar:2.3.0.Beta2-redhat-1,org.jboss.seam:seam-integration-tests:war:2.3.0.Beta2-redhat-1,)

=> use 1.6.1-redhat-1 instead, it is in EAP repo

* jgroups:jgroups:jar:2.6.20.Final
     in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)

=> is there a way how to update to EAP6 jgroups 3 ? ... we don't definitely want to support old JGroups in WFK

* org.drools:drools-compiler:jar:5.2.2.BRMS
     in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
* org.drools:drools-core:jar:5.2.2.BRMS
     in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
* org.drools:drools-decisiontables:jar:5.2.2.BRMS
     in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
* org.drools:drools-templates:jar:5.2.2.BRMS
     in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)

=> apparently we have to package drools or drools have to go to Maven Central

* org.opensymphony.quartz:quartz:jar:1.6.5
     in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)

=> upstream version has different G:A

* oswego-concurrent:concurrent:jar:1.3.4
     in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)

=> upstream version has different G:A
Comment 6 Karel Piwko 2012-05-31 12:25:32 EDT
Additional list, based on suspicious dependency listing:

* org.hibernate:hibernate-tools:3.2.4.GA
    in org.jboss.seam:jboss-seam-gen:2.3.0.Beta2-redhat-1
* org.hibernate:jtidy:r8-20060801
    in org.jboss.seam:jboss-seam-gen:2.3.0.Beta2-redhat-1
Comment 7 Karel Piwko 2012-05-31 13:11:49 EDT
Additional list, based on suspicious dependency listing, continued:

* xerces:xercesImpl:2.9.1
    in  org.jboss.seam:functional-tests:2.3.0.Beta2-redhat-1

=> there is a different version living around

* org.hibernate:hibernate-search-infinispan:4.1.0.CR3

=> should be enterprise version
    in bom, parent


* org.infinispan:infinispan-core:5.1.3.FINAL-redhat-1
=> should be aligned to EAP = 5.1.4-redhat-1
Comment 8 Marek Novotny 2012-05-31 16:17:01 EDT
(In reply to comment #5)
> List of transitive dependencies missing in Seam 2.3 Beta2 in WFK ER7:
> 
> 
> * dom4j:dom4j:jar:1.6.1-brew
>      in
> (org.jboss.seam:distribution:pom:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-
> seam:ejb:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-seam-ioc:jar:2.3.0.Beta2-
> redhat-1,org.jboss.seam:jboss-seam-remoting:jar:2.3.0.Beta2-redhat-1,org.
> jboss.seam:jboss-seam-resteasy:jar:2.3.0.Beta2-redhat-1,org.jboss.seam:jboss-
> seam-ui:jar:2.3.0.Beta2-redhat-1,org.jboss.seam:seam-integration-tests:war:2.
> 3.0.Beta2-redhat-1,)
> 
> => use 1.6.1-redhat-1 instead, it is in EAP repo

that is doable
> 
> * jgroups:jgroups:jar:2.6.20.Final
>      in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
> 
> => is there a way how to update to EAP6 jgroups 3 ? ... we don't definitely
> want to support old JGroups in WFK
not sure, it is there as a compile dep and 3.x doesn't hav eto be API compatible

> 
> * org.drools:drools-compiler:jar:5.2.2.BRMS
>      in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
> * org.drools:drools-core:jar:5.2.2.BRMS
>      in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
> * org.drools:drools-decisiontables:jar:5.2.2.BRMS
>      in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
> * org.drools:drools-templates:jar:5.2.2.BRMS
>      in (org.jboss.seam:jboss-seam:ejb:2.3.0.Beta2-redhat-1,)
> 
> => apparently we have to package drools or drools have to go to Maven Central

Drools are in Central, the thing is that we always build on top SOA productized bits. we can change that and say if customer wants support they have to update to the Drools which are in BRMS
Comment 9 Marek Novotny 2012-05-31 16:19:06 EDT
(In reply to comment #6)
> Additional list, based on suspicious dependency listing:
> 
> * org.hibernate:hibernate-tools:3.2.4.GA
>     in org.jboss.seam:jboss-seam-gen:2.3.0.Beta2-redhat-1
> * org.hibernate:jtidy:r8-20060801
>     in org.jboss.seam:jboss-seam-gen:2.3.0.Beta2-redhat-1

hibernate tools are not released as Maven artifact and we need anyway upgrade to some version which is used/bundled in JBTools. The same applies to jtidy - not possible to change as it is dependent on hibernate tools.
Comment 10 Marek Novotny 2012-05-31 16:21:29 EDT
(In reply to comment #7)
> Additional list, based on suspicious dependency listing, continued:
> 
> * xerces:xercesImpl:2.9.1
>     in  org.jboss.seam:functional-tests:2.3.0.Beta2-redhat-1
> 
> => there is a different version living around
> 
> * org.hibernate:hibernate-search-infinispan:4.1.0.CR3
> 
> => should be enterprise version
>     in bom, paren

Seam doesn't use that and that is coming from BOM javaee-with-hibernate M11-redhat-1

> 
> 
> * org.infinispan:infinispan-core:5.1.3.FINAL-redhat-1
> => should be aligned to EAP = 5.1.4-redhat-1

not necessary. WFK has got special build in WFK repository with built ISPN modules which are not provided by EAP.
Comment 11 Marek Novotny 2012-06-11 17:33:49 EDT
All except hibernate-tools and jtidy were added into WFK maven repository as workaround
Comment 12 Marek Novotny 2012-06-11 17:35:33 EDT
(In reply to comment #11)
> All except hibernate-tools and jtidy were added into WFK maven repository as
> workaround

Hibernate tools are internal release in thirdparty nexus repository and Max from JBoss Tools team doesn't recommend to publish it in repository.
Comment 13 Karel Piwko 2012-06-12 10:37:24 EDT
There are still two artifacts missing in the distribution, however this are not distributed by default in the repository (a.k.a. no ZIP, no WAR rules)


* org.jboss.seam:jboss-seam-gen:zip:distribution:2.3.0.Beta2-redhat-1
     in (org.jboss.seam:distribution:pom:2.3.0.Beta2-redhat-1,)
* org.jboss.seam:seam-integration-tests:war:2.3.0.Beta2-redhat-1
     in (org.jboss.seam:distribution:pom:2.3.0.Beta2-redhat-1,)

The rest seems to be XercesImpl, jtidy and hibernate-tools, which was claimed ok.

Note You need to log in before you can comment on or make changes to this bug.