Bug 814088 - Review Request: fungal - a POJO kernel environment used by Ironjacamar standalone
Review Request: fungal - a POJO kernel environment used by Ironjacamar standa...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: gil cattaneo
Fedora Extras Quality Assurance
NotReady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 04:17 EDT by Lin Gao
Modified: 2015-12-04 03:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 03:37:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lin Gao 2012-04-19 04:17:24 EDT
Spec URL: http://fedorapkgs-gaolin.rhcloud.com/fungal.spec
SRPM URL: http://fedorapkgs-gaolin.rhcloud.com/fungal-0.11.0-0.1.Beta4.fc16.src.rpm
Description: The Fungal kernel project implements a Plain Old Java Object (POJO) kernel environment. It is used by IronJacamar standalone environment.
Comment 1 Lin Gao 2012-04-19 04:21:09 EDT
This is my first package to Fedora, thus needs a sponsor.
Comment 4 Jason Tibbitts 2013-05-08 18:36:00 EDT
I am triaging old review tickets.  I apologize that it has been so long since 
anyone looked at this ticket, but there are more packages submitted now than
the pool of reviewers can handle, and some tickets fall through the cracks.

In order to keep the queue manageable, we need to occasionally find tickets 
which are not reviewable so as to not waste what reviewer time is available.  
Accordingly, I'm pinging this ticket and setting NEEDINFO.  If you are still 
interested in having your package reviewed, please do the following:

* Make sure your package still reflects the current status of its upstream.

* Check that your package still builds on current Fedora releases.

* Audit your package versus the current status of the packaging guidelines, 
  current rpmlint and current fedora-review tools.

And, finally, reply, making sure that the NEEDINFO flag gets cleared so that
this ticket reappears in the review queue.  I can't promise a review if you 
reply, but by closing out the stale tickets we can devote extra attention to 
the ones which aren't stale.
Comment 5 Lin Gao 2013-05-13 02:20:34 EDT
Yes, I am still interested in having this package reviewed.

Upgraded to latest release of fungal:

SPec URL: http://repos.fedorapeople.org/repos/lgao/fungal/fungal.spec
SRPM URL: http://repos.fedorapeople.org/repos/lgao/fungal/fungal-0.11.0-0.1.RC1.fc16.src.rpm

Test koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=5370812
Comment 6 gil cattaneo 2013-05-29 17:27:03 EDT
would like to take this review
Comment 7 gil cattaneo 2013-05-29 17:46:28 EDT
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Javadoc subpackages should not have Requires: jpackage-utils
  Note: jpackage-utils requires are automatically generated by the buildsystem
  See: https://fedoraproject.org/wiki/Packaging:Java
- Bundled jar/class files should be removed before build
  Note: Jar files in source (see attachment)
  See: http://fedoraproject.org/wiki/Packaging:Java#Pre-built_JAR_files_.2F_Other_bundled_software'


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[!]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in fungal-
     javadoc
[x]: Package complies to the Packaging Guidelines
[!]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "LGPL (v2.1 or later)", "Unknown or generated". 123 files have unknown
     license. Detailed output of licensecheck in
     /home/gil/814088-fungal/licensecheck.txt
[!]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

Java:
[x]: Packages have proper BuildRequires/Requires on jpackage-utils
[x]: Fully versioned dependency in subpackages, if present.
[x]: Javadoc documentation files are generated and included in -javadoc
     subpackage
[x]: Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlink)

Maven:
[x]: Pom files have correct Maven mapping
     Note: Some add_maven_depmap calls found. Please check if they are correct
     or update to latest guidelines
[x]: If package contains pom.xml files install it (including depmaps) even
     when building with ant
[x]: Old add_to_maven_depmap macro is not being used
[x]: Packages DOES NOT have Requires(post) and Requires(postun) on jpackage-
     utils for %update_maven_depmap macro
[x]: Package DOES NOT use %update_maven_depmap in %post/%postun
[x]: Packages use %{_mavenpomdir} instead of %{_datadir}/maven2/poms

===== SHOULD items =====

Generic:
[!]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[!]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

Java:
[x]: Package uses upstream build method (ant/maven/etc.)
[x]: Packages are noarch unless they use JNI

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: fungal-0.11.0-0.1.RC1.fc20.noarch.rpm
          fungal-javadoc-0.11.0-0.1.RC1.fc20.noarch.rpm
fungal.noarch: W: incoherent-version-in-changelog 0.11.0-0.1.rc1 ['0.11.0-0.1.RC1.fc20', '0.11.0-0.1.RC1']
fungal-javadoc.noarch: W: spelling-error Summary(en_US) Javadocs -> Java docs, Java-docs, Avocados
2 packages and 0 specfiles checked; 0 errors, 2 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint fungal fungal-javadoc
fungal.noarch: W: incoherent-version-in-changelog 0.11.0-0.1.rc1 ['0.11.0-0.1.RC1.fc20', '0.11.0-0.1.RC1']
fungal-javadoc.noarch: W: spelling-error Summary(en_US) Javadocs -> Java docs, Java-docs, Avocados
2 packages and 0 specfiles checked; 0 errors, 2 warnings.
# echo 'rpmlint-done:'



Jar and class files in source
-----------------------------
./fungal-0.11.0.RC1/bin/com/github/fungal/spi/netboot/Protocol.class
./fungal-0.11.0.RC1/bin/com/github/fungal/spi/deployers/DeployException.class
./fungal-0.11.0.RC1/bin/com/github/fungal/spi/deployers/CloneableDeployer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/spi/deployers/Context.class
./fungal-0.11.0.RC1/bin/com/github/fungal/spi/deployers/DeployerPhases.class
./fungal-0.11.0.RC1/bin/com/github/fungal/spi/deployers/Deployment.class
./fungal-0.11.0.RC1/bin/com/github/fungal/spi/deployers/Deployer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/cli/CLI.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/Bootstrap.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/ServersType.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/DependencyType.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/ProtocolType.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/ServerType.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/ProtocolsType.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/Unmarshaller.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/DependenciesType.class
./fungal-0.11.0.RC1/bin/com/github/fungal/bootstrap/PropertyType.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/remote/Communicator.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/remote/Command.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/events/EventListener.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/classloading/KernelClassLoader.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/classloading/ClassLoaderFactory.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/KernelFactory.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/configuration/DeploymentOrder.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/configuration/KernelConfiguration.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/FileUtil.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/SecurityActions.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/MBeanService.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/JMX$ManagementDelegator.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/Injection.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/JMX$MBeanAttributeComparator.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/JMX.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/JarFilter.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/util/JMX$MBeanOperationComparator.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Create.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Bean.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Start.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Factory.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Parameter.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Inject.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Destroy.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Depends.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Value.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Uninstall.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Set.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Null.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/List.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Constructor.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Stop.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/BeanDeployment.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Uncallback.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Entry.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Map.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Install.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/This.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Key.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Property.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployment/Incallback.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/Kernel.class
./fungal-0.11.0.RC1/bin/com/github/fungal/api/deployer/MainDeployer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/deployment/Deployment.class
./fungal-0.11.0.RC1/bin/com/github/fungal/deployment/Unmarshaller.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/HotDeployer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/HotDeployerMBean.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/CommunicatorImpl.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/commands/Deploy.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/commands/Undeploy.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/commands/Help.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/commands/GetCommand.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/Communication.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/SecurityActions.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/remote/CommunicationServer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/ParentFirstClassLoader.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/ChildrenClassLoader.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/SecurityActions.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/ExportClassLoader.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/NonExportClassLoader.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/ArchiveClassLoader.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/VersionComparator.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/ParentLastClassLoader.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/classloader/ExportClassLoaderRepository.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/MainDeployerImplMBean.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/MainDeployerImpl.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/DeploymentDeployer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/MavenUnmarshaller.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/Http.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/Maven.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/DependencyTracker.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/Repository.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/Netboot.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/AbstractRepository.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/ResolveException.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/Pattern.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/netboot/Netboot$DependencyResolver.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/BeanDeploymentImpl.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/SecurityActions.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/ContextImpl.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/Injection.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/JmxRemote$JMXServerSocketFactory.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/Callback.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/FungalThreadFactory.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/JmxRemote.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/Deployers.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/KernelImplMBean.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/BeanDeployer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/KernelImpl$UnitDeployer.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/JarFilter.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/KernelImpl.class
./fungal-0.11.0.RC1/bin/com/github/fungal/impl/DeployerComparator.class


Requires
--------
fungal (rpmlib, GLIBC filtered):
    jpackage-utils

fungal-javadoc (rpmlib, GLIBC filtered):
    jpackage-utils



Provides
--------
fungal:
    fungal
    mvn(com.github.fungal:fungal)
    mvn(com.github.fungal:fungal-cli)

fungal-javadoc:
    fungal-javadoc



Generated by fedora-review 0.4.1 (b2e211f) last change: 2013-04-29
Buildroot used: fedora-rawhide-i386
Command line :/usr/bin/fedora-review -b 814088 -m fedora-rawhide-i386

not approved

please remove all classes and jar files (if this one are present)
find fungal-0.11.0.RC1/ -name "*.jar" -print
find fungal-0.11.0.RC1/ -name "*.class" -print -delete
remove all jpackage-utils references
can you request developers to include the licensing?
Comment 8 Lin Gao 2013-06-16 19:21:05 EDT
The developer will include a license file in next release, but I need to wait for that. so I will re-submit this package till next release of fungal.
Comment 9 Mikolaj Izdebski 2015-01-26 07:21:38 EST
Package is not ready for rewiew - lifting block on Java SIG. Feel free to add it once ready for review.
Comment 10 gil cattaneo 2015-09-19 04:39:04 EDT
Available fungal-0.11.0-final @ https://github.com/jesperpedersen/fungal/releases/tag/
Comment 11 James Hogarth 2015-12-03 23:09:13 EST
Lin are you able to progress this?

If it's not possible let's close this review to try and tidy up a bit.
Comment 12 Lin Gao 2015-12-04 03:37:02 EST
Sorry, I am too busy for now. Closed it as won'tfix

Note You need to log in before you can comment on or make changes to this bug.