Bug 814122 - [abrt] spice-gtk-tools-0.11-4.fc16: __memmove_ssse3_back: Process /usr/bin/spicy was killed by signal 11 (SIGSEGV)
[abrt] spice-gtk-tools-0.11-4.fc16: __memmove_ssse3_back: Process /usr/bin/sp...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Fedora Extras Quality Assurance
abrt_hash:63a81d77c905c03bb6239ce8f23...
:
: 789404 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 05:40 EDT by u5afe
Modified: 2012-10-21 18:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-21 18:39:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (40.58 KB, text/plain)
2012-04-19 05:40 EDT, u5afe
no flags Details
File: dso_list (8.62 KB, text/plain)
2012-04-19 05:40 EDT, u5afe
no flags Details
File: backtrace (157.54 KB, text/plain)
2012-04-19 05:40 EDT, u5afe
no flags Details

  None (edit)
Description u5afe 2012-04-19 05:40:38 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        spicy -h localhost -p 5900
comment:        After changing from full screen to window the resolution of the guest distplay did not automatically adjust to the new window size. Upon closing and reopening the spicy a crash was detected
crash_function: __memmove_ssse3_back
executable:     /usr/bin/spicy
kernel:         3.3.1-5.fc16.x86_64
pid:            2170
pwd:            /home/anthony
reason:         Process /usr/bin/spicy was killed by signal 11 (SIGSEGV)
time:           Thu 19 Apr 2012 07:22:53 PM EST
uid:            1000
username:       anthony

backtrace:      Text file, 161326 bytes
dso_list:       Text file, 8831 bytes
maps:           Text file, 41559 bytes

build_ids:
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:2e5d5fbc802b4ce878cb203172c10bd9a5ae8822
:ccd23fb93a7924ddd27ea9e7f054fa5309c92f32
:07470201df55a5254027d05fa4dc509b10f2986a
:89017ab0b75e533e4294f74ee8f7db3daceea536
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:50e0538b22a0baf6f774534e80192f74c75ab1f5
:5e8c36ca13a4af14fa6b1b45a0dbfb43ed6aed6e
:d0c6e13f00a20952a72a945c929efb175fd760e3
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:460eb197d84b119c8ba93737cd0e4486a96a0be0
:638db099ff5fb986d1a092629d1bb1dca5be4904
:153ec2281113bcf09581162f9b05279080442fbf
:aaf62304b0fc10611d35b4f56005479d4c58868d
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:cc32e70895d23acd7bde1ef1a3286b5e179e2d49
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:c6458072ad06b0a781aa2311d45aaacdc598e891
:58f626f3815dd6adeb4a543bca2472ab98f2953b
:56cd5a4b8ecf7f375c95a4fd575895efbe294071
:2639b5594fe4d7897db63ecd1ebb9681438317a8
:0fe03f2aa418c7dbfdc2d0d1802a8e86b27d3120
:124bfd663f5587288e6e0da8497fb4153469e657
:ced174aa0f6fc21a03a8891d8b372c68e705c159
:23b6792e3218744316fd495002f40a037c2e0095
:34e8b3cee73a6d0b8ac17c69ba4b1170724db64c
:3f13fafac33a0413af6c8d0f2313914c6984e757
:dc998e8c1e1dc44c684b9b86e753945a868e134a
:ec72f897bbac2f33aadee57e01b7e01bbed4c534
:ef95ed2b74ff19753827117d4e556f38b33e74b5
:f0d50e3af2dfee021a327fb85a993a2312a98145
:0a49b6fd90960659888f0be3bb576495f9d41959
:703ccfe875632e8e2f051812d7db85dcfe43f324
:b092238efe70555aea56f2dd242b7c0fe06d29b6
:4b01fe6e705219deca2756ff0720d52ec81b4c87
:f417b25f83a1b878b1a8965478a7eecf0344eaca
:a0b2903547454e47fec356c1fa1a69a7593893c5
:6ecc3efaedf849a17c30a67fe15b4dacca1bd981
:80954cffbb2bc0618b406fbf426660f2a692a00f
:ea44661a40777d6be2f79058c161d3bb4962891a
:48aea888319e1848137073c9cbde54a4c2a731c9
:4b4285058f7f6b39b7e7c45df83fd36c6833bfe4
:be507c791e34415e8f42f0e6030c889b2895cf9a
:1036beaacbb26135c7273ac5a95e22ca99c89c3a
:3269336f76283d9cebaa8222e0017c80fd14bdf6
:f76b984be770d7d24d6ff99278ca9b18652ec542
:ee2f04900ae1f07517d91eba300ef385fccab1b8
:fd8a00c88eb1fd6872e45001f9ed4e5c6172995e
:aa733447f84020c94a66814e501a36e248cbb43d
:065f24e263b3a0d4316bfeedf855df8c2c35c03a
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:7ddde233293b60ff6de1dabd78d95aa43e47fc23
:ea16e6140d0a62875a7ce7a908ddd843792531e9
:36a149d1e2c29890b616402f6bc5e3f69ca2738e
:12ebe599358398f2c1a5294bb2dd387545474b65
:c8a4e40c84c2f52e78c64d31efc0191c565a9049
:25b834f4c4dc534708635ff1064e2fe02a366a62
:163b323da65b708418226eb5fa8b057c731d1475
:e2e67b3ae2579e1667b73ad385f61552931024e9
:0911ea7c180d733724f89037b8e8a34e64024aec
:ccadad4ec7dab3bb6abc23f9d4cdf53ff01cb235
:f1eb6e4e907e1e42f557c5b8dc851c407c6f4ac4
:dacf32a9a2f2b5077ba944e7b835cca6f637f78f
:4c842320387ff7f6f91b7842b223c16518be909f
:b5cc5510167fc62ecff7cef6f4e92ed168ba28d7
:75eaece6e0d1e075520cdfad5c398fdab4370846
:2976a5f82b01d5dedaaefdd41fa7a78b090c75a1
:d460d68692c1b32346f469e0a9ab3933cf1f3d1c
:e814ef8432b7dec42a0b8ec12b9abd9fc7f57b40
:82cca0d5b06a649072a966dc4f05aded63d736bc
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:2670385f49fb9f120f7cf843f211e3c620da8632
:c1f034e216940c41dbe23880c3400ef9cffae35d
:daec0ba0ef53c9f6c098d2b47f5974fa82aff498
:f1e8182609d9eae40a8ddbbb72c9346166014f1a
:4d5437cf71ea3e4bac1c445da58ca7897d509d15
:1c6a95451ee19617be5abea3d121f0226d21ddda
:36f57a1f3d3f4436f63d1aac473a777597dce5dc
:719a85c49c612de86619fed98146f316432aee92
:616cdfde72c06f8e55b7ac23849c334e7d767bdb
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:e5429e0905bedecc534b057783916ba43e06a66e
:4a7e68edf2778a9fbd3d4a8fbd3f9d1e7b785fc6
:888e650848c123e0c145e1bbf100f639bd8b308e
:1a212c7f1515542b310ba92f6109efc9b5bf2b6e
:1e0de72c7f10f33e0ee489a9a32c4e4f01902580
:b9d3a4213a482d034bebc7dc1ed2901a734a894d
:85e76e7b27f9af4e87ed94c5ca8767d7b758ef40
:76a899f52b82c8c4043482cf7ae9f4b6871aab5c
:e2d68a0ee0872365dcc8c6640b7cd7b94c8276f2
:040f78c63e49df93936f710287bdc74ae83111c0
:652978274d9edf0accf8057af35746fe32ca8b1c
:b0a2d0b4c09d819887ec7d711c8cf3977a074c4f
:a518a8b1b5c3e80dee813df05e951d205d6ac48c

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=1940
:XDG_SESSION_ID=3
:HOSTNAME=shoosh
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GLADE_PIXMAP_PATH=:
:GPG_AGENT_INFO=/home/anthony/.gnupg/S.gpg-agent:1961:1
:SHELL=/bin/bash
:TERM=dumb
:XDG_MENU_PREFIX=xfce-
:XDG_SESSION_COOKIE=9161d87a705d41e7d8acaab30000000f-1334812854.367829-677763756
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/tmp/keyring-GJqcbz
:IMSETTINGS_MODULE=none
:USER=anthony
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-CTELBKTV1810/agent.1810
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1970,unix/unix:/tmp/.ICE-unix/1970
:USERNAME=anthony
:XDG_CONFIG_DIRS=/etc/xdg
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/anthony/.local/bin:/home/anthony/bin
:DESKTOP_SESSION=xfce
:MAIL=/var/spool/mail/anthony
:QT_IM_MODULE=xim
:PWD=/home/anthony
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1806
:LANG=en_US.UTF-8
:GDMSESSION=xfce
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HOME=/home/anthony
:XDG_SEAT=seat0
:SHLVL=3
:LOGNAME=anthony
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ef2pRd4qmj,guid=4082068b4a8c744079282e4100000023
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0.0
:XDG_RUNTIME_DIR=/run/user/anthony
:LIBGLADE_MODULE_PATH=:
:GLADE_CATALOG_PATH=:
:XAUTHORITY=/var/run/gdm/auth-for-anthony-2ulhoZ/database
:_=/usr/bin/spicy

smolt_data:
:
:
:General
:=================================
:UUID: d82ef912-4756-4001-84d0-64aab67a1351
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6784.37
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 3701
:System Memory: 7716
:System Swap: 8191
:Vendor: Gigabyte Technology Co., Ltd.
:System: H67MA-D2H 
:Form factor: Desktop
:Kernel: 3.3.1-5.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:258:5208:53248) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7170:5208:45061) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7184:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7242:5208:20481) pci, None, PCI/ISA, H67 Express Chipset Family LPC Controller
:(32902:7196:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7200:5208:40962) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:5208:20481) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(4147:404:5208:20487) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7213:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:256:0:0) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:5208:7226) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:257:5208:20480) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 7670918 6314695 6237916 1925120 1785874 1785874
:/dev/sdb1 WITHHELD ext4 4096 4096 29262218 712112 0 7331840 7331828 7331828
:/dev/sdc1 WITHHELD fuseblk 4096 4096 244190000 147805682 147805682 591517640 591309988 591309988
:/dev/sda5 /home ext4 4096 4096 18148369 4619432 3710504 4546560 4541954 4541954
:/dev/sda2 /boot ext4 1024 1024 508745 435263 409663 128016 127785 127785
:

var_log_messages:
:Apr 19 19:22:53 shoosh kernel: [ 2180.117836] spicy[2170]: segfault at 7fba283c1004 ip 0000003fb5346c30 sp 00007fff11406bf8 error 4 in libc-2.14.90.so[3fb5200000+1ad000]
:Apr 19 19:22:54 shoosh abrt[4055]: Saved core dump of pid 2170 (/usr/bin/spicy) to /var/spool/abrt/ccpp-2012-04-19-19:22:53-2170 (272678912 bytes)

xsession_errors:
:(spicy:2170): GSpice-WARNING **: keyboard grab failed 1
:/home/anthony/bin/xp.sh: line 2:  2170 Segmentation fault      (core dumped) spicy -h localhost -p 5900
Comment 1 u5afe 2012-04-19 05:40:43 EDT
Created attachment 578558 [details]
File: maps
Comment 2 u5afe 2012-04-19 05:40:45 EDT
Created attachment 578559 [details]
File: dso_list
Comment 3 u5afe 2012-04-19 05:40:50 EDT
Created attachment 578560 [details]
File: backtrace
Comment 4 Marc-Andre Lureau 2012-04-19 08:41:44 EDT
this was fixed in the following commit, and should be part of next release
http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=d16df7dab09c2966227c1f5b915921d4b62bfda9
Comment 5 Cole Robinson 2012-06-17 17:25:51 EDT
*** Bug 789404 has been marked as a duplicate of this bug. ***
Comment 6 Cole Robinson 2012-06-17 17:30:27 EDT
Moving this to POST (MODIFIED means patch is in fedora git, which isn't the case here. At least in virt land we use POST to mean "there's a fix upstream")

Marc-Andre, any chance we can get 0.12 for F16, or a backport of that fix?
Comment 7 Cole Robinson 2012-10-21 18:39:10 EDT
Since this has lingered for a while and a build doesn't seem forthcoming, just closing as NEXTRELEASE. F17 should have the fix

Note You need to log in before you can comment on or make changes to this bug.