Bug 814213 - disabling panning on multihead [NVS 300] caused cursor disappear and black panned output
disabling panning on multihead [NVS 300] caused cursor disappear and black pa...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ben Skeggs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 07:45 EDT by Tomas Pelka
Modified: 2017-12-06 07:35 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:35:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (50.95 KB, text/plain)
2012-04-19 07:48 EDT, Tomas Pelka
no flags Details
xorg.log (80.19 KB, text/plain)
2012-04-19 07:49 EDT, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2012-04-19 07:45:35 EDT
Description of problem:
I just tried panning on multihead setup with NVS300 and after disable panning on firs screen it goes black (seems to be switched to standby) and cursor disappears completely. 

Version-Release number of selected component (if applicable):
kernel-2.6.32-262.el6
xorg-x11-drv-nouveau-0.0.16-13.20110719gitde9d1ba.el6
xorg-x11-server-Xorg-1.10.6-1.el6

How reproducible:
100%

Steps to Reproduce:
1. xrandr --output DP-1 --panning 1600x1200
2. xrandr --output DP-1 --panning 0x0*0+0
3.
  
Actual results:
first screen is black and cursor disappear

Expected results:
all should work

Additional info:


01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [NVS 300] [10de:10d8] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: NVIDIA Corporation Device [10de:0862]
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at f2000000 (32-bit, non-prefetchable) [size=16M]
	Memory at f8000000 (64-bit, prefetchable) [size=64M]
	Memory at fc000000 (64-bit, prefetchable) [size=32M]
	I/O ports at 1100 [size=128]
	[virtual] Expansion ROM at f3080000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [b4] Vendor Specific Information <?>
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information <?>
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb

xrandr after panning diabled

$ xrandr --verbose
Screen 0: minimum 320 x 200, current 2560 x 1024, maximum 8192 x 8192
DP-1 connected 1280x1024+0+0 (0x63) normal (normal left inverted right x axis y axis) 376mm x 301mm
	Identifier: 0x61
	Timestamp:  799107
	Subpixel:   unknown
	Gamma:      1.0:1.0:1.0
	Brightness: 1.0
	Clones:    
	CRTC:       0
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	EDID:
		00ffffffffffff0010ac154036444341
		0111010380261e78eede95a3544c9926
		0f5054a54b00714f8180010101010101
		010101010101302a009851002a403070
		1300782d1100001e000000ff00475536
		3230373134414344360a000000fc0044
		454c4c203139303746500a20000000fd
		00384c1e510e000a2020202020200031
	dithering depth:	auto
		supported: auto         6 bpc        8 bpc       
	dithering mode:	auto
		supported: auto         off          static 2x2   dynamic 2x2 
	scaling mode:	Full
		supported: None         Full         Center       Full aspect 
	underscan vborder: 0 (0x00000000)	range:  (0,128)
	underscan hborder: 0 (0x00000000)	range:  (0,128)
	underscan:	off
		supported: auto         off          on          
  1280x1024 (0x63)  108.0MHz +HSync +VSync *current +preferred
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock   64.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   60.0Hz
  1280x1024 (0x64)  135.0MHz +HSync +VSync
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz
  1152x864 (0x65)  108.0MHz +HSync +VSync
        h: width  1152 start 1216 end 1344 total 1600 skew    0 clock   67.5KHz
        v: height  864 start  865 end  868 total  900           clock   75.0Hz
  1024x768 (0x66)   78.8MHz +HSync +VSync
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock   60.1KHz
        v: height  768 start  769 end  772 total  800           clock   75.1Hz
  1024x768 (0x67)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x68)   49.5MHz +HSync +VSync
        h: width   800 start  816 end  896 total 1056 skew    0 clock   46.9KHz
        v: height  600 start  601 end  604 total  625           clock   75.0Hz
  800x600 (0x69)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x6a)   31.5MHz -HSync -VSync
        h: width   640 start  656 end  720 total  840 skew    0 clock   37.5KHz
        v: height  480 start  481 end  484 total  500           clock   75.0Hz
  640x480 (0x6b)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  720x400 (0x6c)   28.3MHz -HSync +VSync
        h: width   720 start  738 end  846 total  900 skew    0 clock   31.5KHz
        v: height  400 start  412 end  414 total  449           clock   70.1Hz
DP-2 connected 1280x1024+1280+0 (0x63) normal (normal left inverted right x axis y axis) 376mm x 301mm
	Identifier: 0x62
	Timestamp:  799107
	Subpixel:   unknown
	Gamma:      1.0:1.0:1.0
	Brightness: 1.0
	Clones:    
	CRTC:       1
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	EDID:
		00ffffffffffff0010ac154042574c41
		2e10010380261e78eede95a3544c9926
		0f5054a54b00714f8180010101010101
		010101010101302a009851002a403070
		1300782d1100001e000000ff00475536
		3230364243414c57420a000000fc0044
		454c4c203139303746500a20000000fd
		00384c1e510e000a2020202020200096
	dithering depth:	auto
		supported: auto         6 bpc        8 bpc       
	dithering mode:	auto
		supported: auto         off          static 2x2   dynamic 2x2 
	scaling mode:	Full
		supported: None         Full         Center       Full aspect 
	underscan vborder: 0 (0x00000000)	range:  (0,128)
	underscan hborder: 0 (0x00000000)	range:  (0,128)
	underscan:	off
		supported: auto         off          on          
  1280x1024 (0x63)  108.0MHz +HSync +VSync *current +preferred
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock   64.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   60.0Hz
  1280x1024 (0x64)  135.0MHz +HSync +VSync
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz
  1152x864 (0x65)  108.0MHz +HSync +VSync
        h: width  1152 start 1216 end 1344 total 1600 skew    0 clock   67.5KHz
        v: height  864 start  865 end  868 total  900           clock   75.0Hz
  1024x768 (0x66)   78.8MHz +HSync +VSync
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock   60.1KHz
        v: height  768 start  769 end  772 total  800           clock   75.1Hz
  1024x768 (0x67)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x68)   49.5MHz +HSync +VSync
        h: width   800 start  816 end  896 total 1056 skew    0 clock   46.9KHz
        v: height  600 start  601 end  604 total  625           clock   75.0Hz
  800x600 (0x69)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x6a)   31.5MHz -HSync -VSync
        h: width   640 start  656 end  720 total  840 skew    0 clock   37.5KHz
        v: height  480 start  481 end  484 total  500           clock   75.0Hz
  640x480 (0x6b)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  720x400 (0x6c)   28.3MHz -HSync +VSync
        h: width   720 start  738 end  846 total  900 skew    0 clock   31.5KHz
        v: height  400 start  412 end  414 total  449           clock   70.1Hz
[test@dhcp-2-204 root]$
Comment 1 Tomas Pelka 2012-04-19 07:48:56 EDT
Created attachment 578618 [details]
dmesg

dmesg after panning disabled
Comment 2 Tomas Pelka 2012-04-19 07:49:43 EDT
Created attachment 578619 [details]
xorg.log

xorg.log after panning diabled
Comment 3 Tomas Pelka 2012-04-19 08:00:18 EDT
Single head work just fine.
Comment 4 Suzanne Yeghiayan 2012-04-19 16:54:05 EDT
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 5 RHEL Product and Program Management 2012-07-10 02:56:13 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 22:08:30 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 RHEL Product and Program Management 2012-12-14 02:24:26 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Jan Kurik 2017-12-06 07:35:27 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.