Bug 814217 - [userportal] NPEs after sign out
[userportal] NPEs after sign out
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-engine-userportal (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: vszocs
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 07:50 EDT by vszocs
Modified: 2012-05-17 09:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-17 09:31:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vszocs 2012-04-19 07:50:01 EDT
In UserPortal, after signing out, there are some NPEs thrown periodically within the login section, until the user logs in again.

This is because UserPortal's main models [UPBasicListModel, UPListModel, UPTemplateListModel] don't have their refresh timers stopped upon logout.

In WebAdmin, this is achieved via CommonModel, which calls EnsureAsyncSearchStopped on its main models. In UserPortal, there is no CommonModel, and therefore we need to call EnsureAsyncSearchStopped manually on UserPortal main models.
Comment 1 Tomas Jelinek 2012-05-17 09:31:47 EDT
This has been fixed in git: f3e4892d115da95e9f44e0d09c0c073c7eacc62b

Note You need to log in before you can comment on or make changes to this bug.