Bug 814224 - yum uses http_proxy for repos with proxy=_none_
yum uses http_proxy for repos with proxy=_none_
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 08:03 EDT by Marko Myllynen
Modified: 2014-01-21 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 04:05:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-04-19 08:03:15 EDT
Description of problem:
With repositories configured with proxy=_none_ Yum works as expected if ftp/http/https_proxy is not set. However, with http_proxy set Yum tries to use the proxy for such repositories. This will cause Yum to fail to contact repositories which cannot be accessed thru a proxy.

As per IRC discussion, this seems to be caused by Yum not instructing libcurl to ignore the environment variables.

Version-Release number of selected component (if applicable):
Fedora 17 Beta
Comment 1 Zdeněk Pavlas 2012-04-19 10:26:19 EDT
commit 1b73d714a6084351d48db5d41abc985239144475
Comment 2 Fedora Admin XMLRPC Client 2012-04-27 11:24:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.