Bug 814237 - sdap_check_aliases must not error when detects the same user
Summary: sdap_check_aliases must not error when detects the same user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stephen Gallagher
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-19 12:50 UTC by Dmitri Pal
Modified: 2020-05-02 16:52 UTC (History)
5 users (show)

Fixed In Version: sssd-1.8.0-23.el6
Doc Type: Bug Fix
Doc Text:
No documentation required
Clone Of:
Environment:
Last Closed: 2012-06-20 11:56:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 2349 0 None None None 2020-05-02 16:52:10 UTC
Red Hat Product Errata RHBA-2012:0747 0 normal SHIPPED_LIVE sssd bug fix and enhancement update 2012-06-19 19:31:43 UTC

Description Dmitri Pal 2012-04-19 12:50:46 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/1307

When saving aliases, sdap_check_aliases tests if there is another user with primary name as the alias being processed. It however, does not check if it found the user himself. This can lead to errors, which are skipped during RFC2307bis, but can break initgroups of RFC2307.

Comment 1 Jakub Hrozek 2012-04-19 12:57:47 UTC
To reproduce:
1. configure an RFC2307 domain with at least one user that is a member of a group
2. set case_sensitive option to false
3. run id user

Expected results: all the groups are shown
Actual results: the initgroups operation does not finish correctly

Comment 4 Kaushik Banerjee 2012-05-02 08:06:17 UTC
Verified in version sssd-1.8.0-23

Output of beaker automation run:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: case_sensitive11: case_sensitive=false lookup user, group and netgroup
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Stopping sssd: [  OK  ]
:: [   PASS   ] :: Running 'service sssd stop'
:: [   PASS   ] :: Running 'rm -fr /var/lib/sss/db/*.ldb'
Starting sssd: [  OK  ]
[  OK  ]
:: [   PASS   ] :: Running 'service sssd start'
:: [   PASS   ] :: napping for 5 secs...
:: [   PASS   ] :: Running 'restart_clearing_cache'
uid=1111111(user_cs1) gid=1111111(user_cs1_grp1) groups=1111111(user_cs1_grp1)
:: [   PASS   ] :: Running 'id user_cs1 | grep user_cs1_grp1'
uid=1111111(user_cs1) gid=1111111(user_cs1_grp1) groups=1111111(user_cs1_grp1)
:: [   PASS   ] :: Running 'id USER_CS1_Alias | grep user_cs1_grp1'

Comment 5 Stephen Gallagher 2012-06-12 13:51:43 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation required

Comment 7 errata-xmlrpc 2012-06-20 11:56:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html


Note You need to log in before you can comment on or make changes to this bug.