Bug 814252 - Add "provider=..." option to simplify SSSD configuration
Add "provider=..." option to simplify SSSD configuration
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: SSSD Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 09:13 EDT by Dmitri Pal
Modified: 2016-01-18 15:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 15:51:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-04-19 09:13:00 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/1308

Each backend can have multiple providers. In many cases IPA backend is the only one that provides some specific functionality (subdomains, session, hostid, ...). These have to be usually explicitly configured in sssd.conf because default value is usually "none".

After a consultation with Jakub, we agreed that IPA backend should be more self configurable, i.e. only setting {{{id_provider = ipa}}} should be enough and all other providers should be set to the same value.

For this to be possible the best approach is to define init functions for all providers in each backend and not give the name of ID provider as default value to load_backend_module().
Comment 4 Jakub Hrozek 2016-01-18 15:51:28 EST
Thank you taking your time and submitting this request for Red Hat Enterprise
Linux. Unfortunately, this bug was not given a priority and was deferred both
in the upstream project and in Red Hat Enterprise Linux.

Given that we are unable to fulfill this request in following Red Hat
Enterprise Linux releases, I am closing the Bugzilla as DEFERRED. To request
that Red Hat re-considers the decision, please re-open the Bugzilla via
appropriate support channels and provide additional business and/or technical
details about its importance to you.

Note that you can still track this request or even contribute patches in the
referred upstream Trac ticket.

Note You need to log in before you can comment on or make changes to this bug.