Bug 814270 - P2V fail at 100% with error : Can't call method get_path
P2V fail at 100% with error : Can't call method get_path
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Matthew Booth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 09:56 EDT by François BOYER
Modified: 2012-04-20 04:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 04:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François BOYER 2012-04-19 09:56:37 EDT
Description of problem:
I have a RHEV virtualization environment with 2 hypervisors and 1 manager. My goal is to virtualize a Windows 7 physical machine to virtual machine in RHEV. 

To do this, I installed virt-v2v.x86_64 on my manager. I also installed libguestfs-winsupport.x86_64 version 1.0-7.el6 and virtio-win.noarch version 1.4.0-1.el6. 

As I can't install virt-p2v-builder-image on my manager because it doesn't find package available I installed it on another computer with fedora 16 64 bits order to create an image Virt-P2V.iso. Of course I installed the previous packages (virt-v2v, libguestfs and virtio-win) on that distribution before creating my image. 

Then I copied that image on a USB stick format vfat. And i attached an export storage domain (It is in NFS) to my data center.

I started my physical machine to the USB key with Virt-p2v and I proceeded the conversion with 'rhev' method, 'raw' storage format, preallocated 'allocation' storage and default type network defined in the '/etc/virt-v2v.conf' file of my manager.

The conversion reaches 100% but i get the following error:
"Can't call method get_path on an undefined value at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Connection/RHEVTarget.pm line 923".

I don't understand this error.

Version-Release number of selected component (if applicable):
MY MANAGER -->
virt-v2v.x86_64 version 0.8.3-5.el6
libguestfs-winsupport.x86_64 version 1.0-7.el6
virtio-win.noarch version 1.4.0-1.el6

MY FEDORA 16 -->
virt-v2v.x86_64 version 0.8.5-2.fc16
libguestfs-1.16.18-1.fc16.x86_64
No package virtio or virtio-win available.
virt-p2v-image-builder.noarch version 0.8.5-1.fc16

How reproducible:
Restart the process of converting the physical machine with virt-p2v and wait until it reaches 100%.

Steps to Reproduce:
1. Start a physical machine on the image created by virt-p2v-image-builder
2. Make the conversion by transferring data to virt-p2v-server (my manager)
3. Wait until the end of operation (100%)
  
Actual results:
Unable to virtualize a physical machine into a virtual machine

Expected results:
Get a virtual machine of the physical machine to import it into RHEV.

Additional info:
Comment 2 Matthew Booth 2012-04-20 04:28:05 EDT
We don't support virt-p2v in RHEL 6.2, and consequently it wasn't tested. It will be supported in RHEL 6.3, however.

virt-v2v in RHEL 6.2 contained the bug you describe, which was only triggered when doing a p2v. It has already been fixed during the 6.3 QA process. Here's the upstream commit which fixed it:

http://git.fedorahosted.org/git/?p=virt-v2v.git;a=commitdiff;h=786a74f0f1c14cfb54a65ea8c5fc097f612b03a5;hp=30ad6533de58d39b5daa56d9c74b645a5a876a0b

Note You need to log in before you can comment on or make changes to this bug.