This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 814281 - RFE: Show 'Create New Topic' button even when search returns 0 results.
RFE: Show 'Create New Topic' button even when search returns 0 results.
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
urgent Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 10:20 EDT by Stephen Gordon
Modified: 2013-07-01 19:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 19:28:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-04-19 10:20:43 EDT
Description of problem:

When you specify a list of tags and click search the list of topics matching the selected tags and operators is displayed. A button to create new topic, which by default applies the selected tags to the new topic, is also present.

This button does not however appear if no search results were returned and you want to create the first topic with the selected group of tags. It's possible to work around this by going back to the original search screen (rather than the results page) and clicking create new topic there but it would be useful to be able to do it directly from the results page. 

I think from memory the 'Back to search' button also fails to display if there are no results so you have to use the browser's back button to get back to the search page. This isn't a big deal but it's inconsistent because this option should work and be available regardless of whether there are results or not, arguably you are in fact even more likely to want to click 'Back to search' when there are no results than when there are some.
Comment 1 Lee Newson 2012-07-11 18:52:17 EDT
Done.

There is now the "Create New Topic" and "Back To Search" buttons below the "No results found" message.
Comment 2 Lee Newson 2012-08-28 19:55:18 EDT
Released in Build 20120817-1046.

Note You need to log in before you can comment on or make changes to this bug.