Bug 81431 - gnome-font-properties crashes when selecting installed truetype fonts
gnome-font-properties crashes when selecting installed truetype fonts
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: fontconfig (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-09 08:12 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 14:07:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from 'ls -l' (3.90 KB, text/plain)
2003-01-16 06:21 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-01-09 08:12:30 EST
Description of problem:
After installing tt fonts, gnome-font-properties starts crashing when selecting
any of them. Below is the stack trace:
Backtrace was generated from '/usr/bin/gnome-font-properties'

(no debugging symbols found)...0x407c0bc2 in waitpid ()
   from /lib/i686/libpthread.so.0
#0  0x407c0bc2 in waitpid () from /lib/i686/libpthread.so.0
#1  0x400a62e5 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x4089e9f6 in FcConfigAdd () from /usr/lib/libfontconfig.so.1
#4  0x4089edc5 in FcConfigSubstituteWithPat () from /usr/lib/libfontconfig.so.1
#5  0x408a5c3a in FcFontRenderPrepare () from /usr/lib/libfontconfig.so.1
#6  0x408a5f11 in FcFontSetMatch () from /usr/lib/libfontconfig.so.1
#7  0x408a60eb in FcFontMatch () from /usr/lib/libfontconfig.so.1
#8  0x405060e6 in _pango_xft_font_desc_from_pattern ()
   from /usr/lib/libpangoxft-1.0.so.0
#9  0x40538615 in pango_font_face_describe () from /usr/lib/libpango-1.0.so.0
#10 0x40289bc7 in gtk_font_selection_new () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x42029555 in bsearch () from /lib/i686/libc.so.6
#12 0x42029424 in bsearch () from /lib/i686/libc.so.6
#13 0x42029718 in qsort () from /lib/i686/libc.so.6
#14 0x40289d67 in gtk_font_selection_new () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x40289851 in gtk_font_selection_new () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x4079a3a7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#17 0x40786e17 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#18 0x4079a016 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#19 0x40799268 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#20 0x40799494 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#21 0x4038889a in _gtk_tree_selection_internal_select_node ()
   from /usr/lib/libgtk-x11-2.0.so.0
#22 0x403a34dd in gtk_tree_view_set_reorderable ()
   from /usr/lib/libgtk-x11-2.0.so.0
#23 0x403935a4 in gtk_tree_view_get_type () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x402c252c in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#25 0x40787187 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#26 0x40786e17 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#27 0x40799b6c in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#28 0x4079906f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#29 0x40799494 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#30 0x403bae7e in gtk_widget_send_expose () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x402c22e4 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x402c0e4a in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#33 0x4049cd05 in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#34 0x407e87d5 in g_get_current_time () from /usr/lib/libglib-2.0.so.0
#35 0x407e9678 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0x407e998d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0x407ea08f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#38 0x402c066f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#39 0x0804dde7 in main ()
#40 0x42015970 in __libc_start_main () from /lib/i686/libc.so.6

Version-Release number of selected component (if applicable):
control-center-2.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. Copy tt fonts to /usr/share/local/fonts/TrueType
2. Run ttmkfdir & mkfontdir & chkfontpath -f -a
3. Edit /etc/fonts/fonts.conf: add "<dir>/usr/local/share/fonts/TrueType</dir>"
and uncomment subpixel antialiasing section.
4. Reboot
5. Click Preferences/Font/Application font and choose any installed tt font
Comment 1 Owen Taylor 2003-01-15 17:41:17 EST
What fonts did you install this way? 

(BTW, the release notes weren't very good on this subject. 
The right way to install fonts is to make /usr/share/fonts/local/
copy your fonts to there, and then run fc-cache. As long
as you put your fonts somewhere inside /usr/share/fonts, no editing
of /etc/fonts/fonts.conf is needed. But I don't think that's
relevant. More likely, fontconfig is having problems with your
fonts.)

Comment 2 Need Real Name 2003-01-16 06:21:31 EST
Created attachment 89408 [details]
Output from 'ls -l'
Comment 3 Need Real Name 2003-01-16 06:24:03 EST
I tried as you said to no avail. Here is what I did:
1. mkdir /usr/share/fonts/local
2. cp /usr/local/share/fonts/TrueType/*.ttf /usr/share/fonts/local
3. edited /etc/fonts/fonts.conf to remove dir /usr/local/...
4. chkfontpath -r /usr/local/...
5. fc-cache
6. reboot [just in case:)]
7. choosing 'verdana' in gnome-font-properties makes it explode.
The tt fonts I copied from my windows 2k partition.
Attached is the installed font list.
Comment 4 Owen Taylor 2003-01-16 12:46:16 EST
 A) Copied all the fonts from WinXP to /usr/share/fonts/local
 B) ran fc-cache
 C) Ran gnome-font-properties
 D) Switched the font to Verdana

Using packages from recent Raw Hide. And it worked fine. (The X font path 
stuff is irrelevant here, as it happens)

So, pretty hard for me to debug. Could you:

 1) Grab the gdb package from Rawhide and the fontconfig packages
    (including fontconfig-debuginfo) from 
      http://people.redhat.com/otaylor/tmp/fcpackage-rpms
 2) Install them
 3) Repeat your procedure
 4) Attach the backtrace you get then?

This will give debug symbols and sources for fontconfig, which 
may make it easier for me to figure out why it is crashing.
Comment 5 Owen Taylor 2004-11-08 14:07:48 EST
No information, closing.

Note You need to log in before you can comment on or make changes to this bug.