Bug 814320 - Memory leak in darktable 1.0
Memory leak in darktable 1.0
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: darktable (Show other bugs)
15
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Edouard Bourguignon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 11:15 EDT by kubrick@fgv6.net
Modified: 2012-05-10 03:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 03:19:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kubrick@fgv6.net 2012-04-19 11:15:38 EDT
Description of problem:
Darktable is leaking memory pretty rapidly in darkroom mode when browsing through pictures. After a dozen pictures, darktable can consume a few GB.

Version-Release number of selected component (if applicable):
1.fc15

How reproducible:
All the time

Steps to Reproduce:
1.Import a folder
2.Display a picture in darkroom, double click on another picture, and another one...
3.
  
Actual results:
Memory consumption increases constantly and rapidly.

Expected results:


Additional info:
Tested with both JPEG and NEF
Comment 1 Edouard Bourguignon 2012-04-20 04:52:10 EDT
and when you click back on an already opened picture, is the memory increasing?

I try to reproduce the problem on my Fedora 16, I get the same result but I'm not sure it's a memory leak, could be just a cache system.
Comment 2 kubrick@fgv6.net 2012-04-20 08:40:01 EDT
(In reply to comment #1)
> and when you click back on an already opened picture, is the memory increasing?
> 
No.
> I try to reproduce the problem on my Fedora 16, I get the same result but I'm
> not sure it's a memory leak, could be just a cache system.

It probably is, the problem being that after ten 12px images, the memory usage is 2.1G even if I set low memory usage limits (800MB for tiles). And then swapping begins and it becomes unusable and this memory seems never to be freed.

Maybe I don't understand how the memory limit works in that case, darktable is just a memory hog and is pretty unusable, even with 4GB of RAM.

François.
Comment 3 Edouard Bourguignon 2012-04-20 11:00:45 EDT
François, I remember some threads about memory usage in the darktable-devel mailing list. I think you should ask there (or in their archives) about your darktable memory usage, to be sure it's not a memory leak. Not sure I can do anything else since it's not a rpm/fedora issue.

I've heard about the 1.0.1 release comming at the end of this month, may be it will adress this issue. I will look for any memory issue in their post-1.0.0 branch.
Comment 4 Edouard Bourguignon 2012-05-10 03:19:50 EDT
1.0.3 is in the updates, and it seems more stable with the memory usage. I close this bug but feel free to reopen it if problem persists.

Note You need to log in before you can comment on or make changes to this bug.