Bug 814325 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the file .XauthZDqIuc.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' acc...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:bc46cb744f9e5f234aef929a94d...
:
: 816343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 11:24 EDT by Jiří Martínek
Modified: 2012-06-22 09:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 09:30:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Martínek 2012-04-19 11:24:43 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.2-1.fc17.x86_64
time:           Čt 19. duben 2012, 17:21:57 CEST

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the file .XauthZDqIuc.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed read access on the .XauthZDqIuc file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:xdm_tmp_t:s0
:Target Objects                .XauthZDqIuc [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Neznámé>
:Host                          (removed)
:Source RPM Packages           xulrunner-11.0-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-114.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.2-1.fc17.x86_64 #1 SMP Fri Apr
:                              13 20:23:49 UTC 2012 x86_64 x86_64
:Alert Count                   31
:First Seen                    Čt 19. duben 2012, 16:49:10 CEST
:Last Seen                     Čt 19. duben 2012, 17:12:10 CEST
:Local ID                      684cd58e-29e5-48cd-8e0a-02096f4b754c
:
:Raw Audit Messages
:type=AVC msg=audit(1334848330.778:369): avc:  denied  { read } for  pid=6462 comm="plugin-containe" name=".XauthZDqIuc" dev="sda2" ino=4419 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_tmp_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1334848330.778:369): arch=x86_64 syscall=access success=no exit=EACCES a0=7fff0d439e78 a1=4 a2=7 a3=fffffffffffffbcc items=0 ppid=6388 pid=6462 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=9 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,xdm_tmp_t,file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-04-19 13:46:08 EDT
How did you get this to happen?
Comment 2 Jiří Martínek 2012-04-20 05:47:12 EDT
Not sure now, I will try to repeat it and let you know.
(In reply to comment #1)
> How did you get this to happen?
Comment 3 Miroslav Grepl 2012-04-26 07:37:19 EDT
*** Bug 816343 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-06-22 09:30:11 EDT
Please reopen the bug if you are able to reproduce it. Thank you.

Note You need to log in before you can comment on or make changes to this bug.