Bug 814328 - Cannot push builds
Cannot push builds
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-fedorapackager (Show other bugs)
17
All Linux
high Severity high
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 11:32 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 16:03:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-04-19 11:32:28 EDT
What steps will reproduce the problem?
1. 
2. 
3. 


-- Error Details --
Date: Thu Apr 19 17:31:17 CEST 2012
Message: Failed failed.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.fedoraproject.eclipse.packager
Session Data:
eclipse.buildId=I20120417-1000
java.version=1.7.0_b147-icedtea
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -debug -clean -consolelog

Exception Stack Trace:
org.fedoraproject.eclipse.packager.koji.api.errors.KojiHubClientLoginException: Failed failed.
	at org.fedoraproject.eclipse.packager.koji.api.KojiSSLHubClient.doSslLogin(KojiSSLHubClient.java:111)
	at org.fedoraproject.eclipse.packager.koji.api.KojiSSLHubClient.login(KojiSSLHubClient.java:80)
	at org.fedoraproject.eclipse.packager.koji.api.KojiBuildCommand.call(KojiBuildCommand.java:195)
	at org.fedoraproject.eclipse.packager.koji.api.KojiBuildJob.run(KojiBuildJob.java:134)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.apache.xmlrpc.XmlRpcException: Failed to read server's response: handshake alert:  unrecognized_name
	at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:161)
	at org.apache.xmlrpc.client.XmlRpcHttpTransport.sendRequest(XmlRpcHttpTransport.java:143)
	at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.sendRequest(XmlRpcSunHttpTransport.java:69)
	at org.apache.xmlrpc.client.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:56)
	at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:167)
	at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:158)
	at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:147)
	at org.fedoraproject.eclipse.packager.koji.api.KojiSSLHubClient.doSslLogin(KojiSSLHubClient.java:105)
	... 4 more
Caused by: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
	at sun.security.ssl.ClientHandshaker.handshakeAlert(ClientHandshaker.java:1288)
	at sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:1936)
	at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1059)
	at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1294)
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1321)
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1305)
	at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:523)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
	at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1087)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:250)
	at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.writeRequest(XmlRpcSunHttpTransport.java:104)
	at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:151)
	... 11 more
Comment 1 Krzysztof Daniel 2012-04-19 12:33:20 EDT
eclipse-shelled-2.0.1-2.fc17.noarch
eclipse-fedorapackager-0.3.1-3.fc18.noarch
eclipse-jgit-1.3.0-1.fc18.noarch
eclipse-dtp-1.10-0.2.M6.fc17.noarch
eclipse-mylyn-tasks-bugzilla-3.7.0-3.fc17.noarch
eclipse-gef-examples-3.8.0-0.3.20120402.fc18.noarch
eclipse-egit-1.3.0-1.fc18.noarch
eclipse-pde-4.2.0-0.15.I201204171000.fc18.x86_64
eclipse-cdt-8.0.1-5.fc18.x86_64
eclipse-mylyn-context-team-3.7.0-1.fc18.noarch
eclipse-rse-3.3.1-1.fc18.noarch
eclipse-emf-2.8.0-0.6.postM6.fc18.noarch
eclipse-mylyn-ide-3.7.0-1.fc18.noarch
eclipse-rpm-editor-0.10.0-1.fc18.x86_64
eclipse-mylyn-builds-hudson-3.7.0-2.fc17.noarch
icu4j-eclipse-4.4.2.2-11.fc18.noarch
eclipse-emf-xsd-sdk-2.8.0-0.6.postM6.fc18.noarch
eclipse-mylyn-context-java-3.7.0-1.fc18.noarch
eclipse-birt-chart-4.2.0-0.2.M6.fc17.noarch
eclipse-rcp-4.2.0-0.15.I201204171000.fc18.x86_64
eclipse-mylyn-commons-3.7.0-11.fc17.noarch
eclipse-testframework-3.8.0-0.1.fc18.noarch
eclipse-dltk-4.0.0-0.1.201201070225cvs.fc18.noarch
eclipse-emf-sdk-2.8.0-0.6.postM6.fc18.noarch
eclipse-mylyn-context-3.7.0-1.fc18.noarch
eclipse-mylyn-docs-wikitext-3.7.0-1.fc18.noarch
eclipse-mylyn-context-cdt-3.7.0-1.fc18.noarch
maven-eclipse-plugin-2.9-1.fc18.noarch
eclipse-mylyn-builds-3.7.0-2.fc17.noarch
eclipse-emf-core-2.8.0-0.15.I201204171000.fc18.x86_64
eclipse-jdt-4.2.0-0.15.I201204171000.fc18.x86_64
tomcat5-jasper-eclipse-5.5.31-4.fc17.noarch
eclipse-mylyn-versions-cvs-3.7.0-1.fc18.noarch
eclipse-mylyn-tasks-trac-3.7.0-3.fc17.noarch
eclipse-mylyn-3.7.0-3.fc17.noarch
eclipse-gef-3.8.0-0.3.20120402.fc18.noarch
eclipse-wtp-common-3.3.1-3.fc17.noarch
eclipse-emf-examples-2.8.0-0.6.postM6.fc18.noarch
eclipse-platform-4.2.0-0.15.I201204171000.fc18.x86_64
eclipse-mylyn-tasks-web-3.7.0-3.fc17.noarch
eclipse-gef-sdk-3.8.0-0.3.20120402.fc18.noarch
eclipse-debuginfo-4.2.0-0.15.I201204171000.fc18.x86_64
eclipse-changelog-2.7.0-3.fc17.x86_64
eclipse-wtp-sourceediting-3.3.1-2.fc17.noarch
eclipse-manpage-0.9.0-2.fc17.noarch
eclipse-emf-xsd-2.8.0-0.6.postM6.fc18.noarch
eclipse-mylyn-versions-3.7.0-1.fc18.noarch
eclipse-rpmstubby-0.10.0-1.20120402git2adb2a7.fc18.noarch
eclipse-swt-4.2.0-0.15.I201204171000.fc18.x86_64
Comment 2 Severin Gehwolf 2012-04-19 17:30:15 EDT
This is upstream bug: https://fedorahosted.org/eclipse-fedorapackager/ticket/159 and should have been fixed. Chris, how would I reproduce? What happens if you set the system property manually on the command line? I.e. adding -Djsse.enableSNIExtension=false to eclipse.ini or similar?
Comment 3 Krzysztof Daniel 2012-04-20 07:44:12 EDT
It works then.
Comment 4 Severin Gehwolf 2012-04-20 10:09:55 EDT
Hmm, the fix should do the same (sets the property programmatically). I'm not sure why you experienced this. Are you still able to trigger this problem without the manual properties entry?
Comment 5 Alexander Kurtakov 2012-05-10 16:03:25 EDT
Fixed after the change to koji config to send servername.

Note You need to log in before you can comment on or make changes to this bug.