Bug 814381 - RANDRful mga support has rendering corruption
Summary: RANDRful mga support has rendering corruption
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-mga
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-19 18:03 UTC by Bill Sanford
Modified: 2012-06-20 14:35 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-drv-mga-1.4.13-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 14:35:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
Xorg log file (128.28 KB, text/x-log)
2012-04-20 14:09 UTC, Bill Sanford
no flags Details
dmesg output (43.13 KB, application/octet-stream)
2012-04-20 14:15 UTC, Bill Sanford
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0940 0 normal SHIPPED_LIVE xorg-x11-drv-mga enhancement update 2012-06-19 21:00:27 UTC

Description Bill Sanford 2012-04-19 18:03:22 UTC
Description of problem:
Application windows disappearing when moving them in RHEL. 

Version-Release number of selected component (if applicable):
RHEL6.3-20120416.0

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL6.3-20120416.0.
2. Open up a terminal window.
3. Drag window from title bar.
  
Actual results:
Windows disappearing from view.

Expected results:
Windows can be dragged around the desktop.

Additional info:
Showed ajax what was happening.

Comment 3 Bill Sanford 2012-04-20 14:03:39 UTC
lspci -nn | grep VGA

1c:00.0 VGA compatible controller [0300]: Matrox Graphics, Inc. MGA G200e [Pilot] ServerEngines (SEP1) [102b:0522] (rev 02)

Comment 4 Bill Sanford 2012-04-20 14:09:07 UTC
Created attachment 579009 [details]
Xorg log file

Comment 5 Bill Sanford 2012-04-20 14:15:12 UTC
Created attachment 579010 [details]
dmesg output

Comment 6 Adam Jackson 2012-04-24 22:00:42 UTC
Need to default to shadowfb for randr 1.2 support.  Fix in hand, devel ack.

Comment 7 RHEL Program Management 2012-04-24 22:10:40 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 10 Bill Sanford 2012-05-29 14:43:08 UTC
Verified with xorg-x11-drv-mga-1.4.13-7.el6.

Comment 12 errata-xmlrpc 2012-06-20 14:35:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0940.html


Note You need to log in before you can comment on or make changes to this bug.