Bug 814385 - Release dropdown creates a traceback
Release dropdown creates a traceback
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Adrian Likins
Eric Sammons
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-19 14:28 EDT by J.C. Molet
Modified: 2012-07-17 09:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:04:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2012-04-19 14:28:38 EDT
Description of problem:
When you click on the drop down to select your release version in subscription-manager-gui's preferences, a traceback occurs.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-0.99.14-1.el6.x86_64
subscription-manager-gnome-0.99.14-1.el6.x86_64
subscription-manager-0.99.14-1.el6.x86_64
python-rhsm-0.99.8-1.el6.noarch

(running RHEL6.3-20120416.0 beta workstation)

How reproducible:
Always

Steps to Reproduce:
1. install rhsm
2. (optional?) set hostname = subscription.rhn.stage.redhat.com in rhsm.conf
   2a. register in rhsm-gui (I used 'stage_test_24' for workstaton)
3. open the system prefrences dialog
4. click the dropdown to select your release
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/preferences.py", line 146, in _release_changed
    release=new_release)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 613, in updateConsumer
    ret = self.conn.request_put(method, params)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 396, in request_put
    return self._request("PUT", method, params)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 348, in _request
    self.validateResponse(result)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 374, in validateResponse
    raise RestlibException(response['status'], error_msg)
rhsm.connection.RestlibException: Runtime Error Could not execute JDBC batch update at com.mysql.jdbc.PreparedStatement.executeBatchSerially:1,666

Expected results:
no traceback!

Additional info:
Things seem to work despite that traceback.
Comment 1 J.C. Molet 2012-04-19 14:46:13 EDT
Ignore the 'additional info' above... it looks like setting the release DOES NOT PERSIST once you hit close.  This makes this feature unusable in the gui.
Comment 2 J.C. Molet 2012-04-19 14:54:48 EDT
using the CLI against the stage server:


[root@jmolet-rhel63beta-workstation product]# subscription-manager release --list
5.7
5.8
5Client
6.0
6.1
6.2
6Workstation
[root@jmolet-rhel63beta-workstation product]# subscription-manager release --set=6.2
Runtime Error Could not execute JDBC batch update at com.mysql.jdbc.PreparedStatement.executeBatchSerially:1,666
Comment 3 Adrian Likins 2012-04-19 16:22:06 EDT
I'm having trouble reproducing this against a standalone 0.5.26-2, so
I suspect this is an issue with the schema in stage. 

Can anyone take a look at the logs and check?

There was a schema change for 0.5.26-2...
Comment 5 Adrian Likins 2012-04-20 09:43:27 EDT
It's missing schema in stage. But when investigating we also noticed that releasever is a bytea, so we are going to rev candlepin to go ahead and make the schema correct, then hotfix it, and update the stage/etc schema to new version.
Comment 8 John Sefler 2012-05-10 19:51:10 EDT
Verifying Version...

[root@qe-blade-13 ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.99.17-1.el6.x86_64
candlepin-it-jars: 0.5.26.1-1
candlepin-jboss: 0.5.26.3-1.el6_2


[root@qe-blade-13 ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@qe-blade-13 ~]# subscription-manager register --username stage_test_12
Password: 
The system has been registered with id: 4738ac40-5fab-40a7-98d4-f1f5fb4ca1e1 
[root@qe-blade-13 ~]# subscription-manager-gui&

In the GUI: Auto-subscribe and use System Preferences to set Release: 6.2

[root@qe-blade-13 ~]# subscription-manager release
Release: 6.2

In the GUI: Auto-subscribe and use System Preferences to set Release: ""

[root@qe-blade-13 ~]# subscription-manager release
Release not set

In the GUI: Auto-subscribe and use System Preferences to set Release: 6Server

[root@qe-blade-13 ~]# subscription-manager release
Release: 6Server



^^^ VERIFIED: The GUI System Preferences dialog can be successfully used to set and persist the Release version.
Comment 9 Bryan Kearney 2012-07-17 09:04:10 EDT
Marking all community bugs modified or beyong as closed.

Note You need to log in before you can comment on or make changes to this bug.