This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 814394 - [abrt] crash in hplip-3.11.5-1.fc13: wifisetupdialog.py:296:performScan:TypeError: performScan() takes at least 2 arguments (1 given)
[abrt] crash in hplip-3.11.5-1.fc13: wifisetupdialog.py:296:performScan:TypeE...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
13
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:ae2e75eb
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 14:50 EDT by Michael Reed
Modified: 2012-04-20 07:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 07:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (642 bytes, text/plain)
2012-04-19 14:50 EDT, Michael Reed
no flags Details

  None (edit)
Description Michael Reed 2012-04-19 14:50:06 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/hp-setup -u
component: hplip
executable: /usr/bin/hp-setup
kernel: 2.6.33.6-147.fc13.i686
package: hplip-3.11.5-1.fc13
reason: wifisetupdialog.py:296:performScan:TypeError: performScan() takes at least 2 arguments (1 given)
release: Fedora release 13 (Goddard)

backtrace
-----
wifisetupdialog.py:296:performScan:TypeError: performScan() takes at least 2 arguments (1 given)

Traceback (most recent call last):
  File "/usr/share/hplip/ui4/wifisetupdialog.py", line 689, in NextButton_clicked
    self.showNetworkPage()
  File "/usr/share/hplip/ui4/wifisetupdialog.py", line 278, in showNetworkPage
    self.performScan()
  File "/usr/share/hplip/ui4/wifisetupdialog.py", line 296, in performScan
    self.networks = wifi.performScan(self.dev)
TypeError: performScan() takes at least 2 arguments (1 given)

Local variables in innermost frame:
self: <ui4.wifisetupdialog.WifiSetupDialog object at 0xa343d2c>
error: False

How to reproduce
-----
1.tried to install printer with usb cable connected

2.ran install program in HPLIP gui
3.
Comment 1 Michael Reed 2012-04-19 14:50:09 EDT
Created attachment 578738 [details]
File: backtrace
Comment 2 Jiri Popelka 2012-04-20 07:04:33 EDT
Thank you for the report,
however we can't fix this problem because Fedora 13 has no longer been
supported.

Note You need to log in before you can comment on or make changes to this bug.