Bug 814396 - yum install fail2ban package misconfigured for CentOS6
Summary: yum install fail2ban package misconfigured for CentOS6
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: fail2ban
Version: el6
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Adam Miller
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2012-04-19 18:52 UTC by unicapitals
Modified: 2012-10-11 18:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-10-11 18:40:11 UTC
Type: Bug

Attachments (Terms of Use)

Description unicapitals 2012-04-19 18:52:14 UTC
I have CentOS6 Linux 2.6.32-220.7.1.el6.x86_64
trying to install fail2ban using 
yum install fail2ban

**I have the following error**
Loaded plugins: priorities
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package fail2ban.noarch 0:0.8.4-29.el5 will be installed
--> Processing Dependency: python-inotify for package: fail2ban-0.8.4-29.el5.noarch
--> Running transaction check
---> Package python-inotify.noarch 0:0.9.1-1.el5 will be installed
--> Processing Dependency: python(abi) = 2.4 for package: python-inotify-0.9.1-1.el5.noarch
--> Finished Dependency Resolution
**Error: Package: python-inotify-0.9.1-1.el5.noarch (epel)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-29.el6.x86_64 (@anaconda-CentOS-201112102333.x86_64/6.2)**
               python(abi) = 2.6
           Available: python26-2.6.5-6.el5.x86_64 (epel)
               python(abi) = 2.6

Seems a missing file or not updated configuration in fail2ban.noarch 0:0.8.4-29.el5 as it still wants python(abi) = 2.4 but CentOS6 already has python(abi) = 2.6.
**Hopefully will be fixed asap...please, inform if possible**

Thank you and regards,

Comment 1 Leonard den Ottolander 2012-06-18 13:04:30 UTC
You might want to configure your system to use EPEL 6, not EPEL 5.

Note You need to log in before you can comment on or make changes to this bug.