Bug 814396 - yum install fail2ban package misconfigured for CentOS6
yum install fail2ban package misconfigured for CentOS6
Product: Fedora EPEL
Classification: Fedora
Component: fail2ban (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Miller
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-19 14:52 EDT by unicapitals
Modified: 2012-10-11 14:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-11 14:40:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description unicapitals 2012-04-19 14:52:14 EDT
I have CentOS6 Linux 2.6.32-220.7.1.el6.x86_64
trying to install fail2ban using 
yum install fail2ban

**I have the following error**
Loaded plugins: priorities
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package fail2ban.noarch 0:0.8.4-29.el5 will be installed
--> Processing Dependency: python-inotify for package: fail2ban-0.8.4-29.el5.noarch
--> Running transaction check
---> Package python-inotify.noarch 0:0.9.1-1.el5 will be installed
--> Processing Dependency: python(abi) = 2.4 for package: python-inotify-0.9.1-1.el5.noarch
--> Finished Dependency Resolution
**Error: Package: python-inotify-0.9.1-1.el5.noarch (epel)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-29.el6.x86_64 (@anaconda-CentOS-201112102333.x86_64/6.2)**
               python(abi) = 2.6
           Available: python26-2.6.5-6.el5.x86_64 (epel)
               python(abi) = 2.6

Seems a missing file or not updated configuration in fail2ban.noarch 0:0.8.4-29.el5 as it still wants python(abi) = 2.4 but CentOS6 already has python(abi) = 2.6.
**Hopefully will be fixed asap...please, inform if possible**

Thank you and regards,
Comment 1 Leonard den Ottolander 2012-06-18 09:04:30 EDT
You might want to configure your system to use EPEL 6, not EPEL 5.

Note You need to log in before you can comment on or make changes to this bug.