Bug 814397 - nautilus-open-terminal fails to pick up profile "run command as a login shell"
nautilus-open-terminal fails to pick up profile "run command as a login shell"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nautilus-open-terminal (Show other bugs)
6.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Alexander Larsson
Desktop QE
: Reopened
Depends On:
Blocks: 782183 1002711
  Show dependency treegraph
 
Reported: 2012-04-19 14:53 EDT by Stuart Newman
Modified: 2015-10-01 03:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-31 17:04:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Newman 2012-04-19 14:53:32 EDT
Description of problem:I set the "run command as a login shell in the profile"
When I right click the desktop and select open in terminal, the terminal session does not run as a login shell.  If the terminal is started from the applications->terminal, the session does start as a login shell.


Version-Release number of selected component (if applicable):nautlius-open-terminal 0.17-4.  Fixed in 0.18.


How reproducible:Always


Steps to Reproduce:
1.Set "run command as a login shell"
2.Right click desktop
3.Select open in terminal
  
Actual results: Does not run command as a login shell


Expected results:run command as a login shell


Additional info:
Comment 2 RHEL Product and Program Management 2012-07-10 03:59:26 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 20:02:51 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 RHEL Product and Program Management 2012-09-07 01:27:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Stuart Newman 2012-10-12 06:56:56 EDT
(In reply to comment #4)
> This request was evaluated by Red Hat Product Management for
> inclusion in the current release of Red Hat Enterprise Linux.
> Because the affected component is not scheduled to be updated
> in the current release, Red Hat is unable to address this
> request at this time.
> 
> Red Hat invites you to ask your support representative to
> propose this request, if appropriate, in the next release of
> Red Hat Enterprise Linux.

Please continue to work on this for the appropriate release.
Comment 7 Tomáš Bžatek 2012-10-15 07:31:42 EDT
(In reply to comment #0)
> Version-Release number of selected component (if
> applicable):nautlius-open-terminal 0.17-4.  Fixed in 0.18.

Does 0.18 really work for you? Since the 0.18 release only includes translation updates and a patch that has been packaged in 0.17-4 (bug 640496).
Comment 8 Stuart Newman 2012-10-15 14:19:30 EDT
(In reply to comment #7)
> (In reply to comment #0)
> > Version-Release number of selected component (if
> > applicable):nautlius-open-terminal 0.17-4.  Fixed in 0.18.
> 
> Does 0.18 really work for you? Since the 0.18 release only includes
> translation updates and a patch that has been packaged in 0.17-4 (bug
> 640496).

We only cites 0.18 because the gnome web site seemed to indicate that the problem was fixed.  We have determined that the real problem was introduced by the -l patch that was retrofitted from 0.18.  We removed the patch and the problem went away.  Also pertinent to the issue, the behavior is exhibited by ksh an d csh.
Comment 12 Andrius Benokraitis 2013-10-06 21:33:24 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6, and will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.
Comment 13 Stuart Newman 2013-11-06 14:27:10 EST
This is definitely a bug.  It was introduced by changes made going from nautilus-open-terminal from 0.17.3 to 0.17-4.  To work around the issue, I have to downgrade nautilus-open-terminal back to 0.17-3.  The patch from upstream needs to be examined and fixed.
Comment 14 RHEL Product and Program Management 2013-11-06 14:51:01 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 16 Simone Tolotti 2014-10-08 09:23:03 EDT
Experiencing the same bug in Fedora 21 with nautilus-open-terminal 0.20-3.fc21
Comment 18 Frantisek Zak 2014-11-06 03:27:41 EST
Hello, any updates?
Comment 20 Chris Williams 2015-07-31 17:04:25 EDT
Closing per comment 12

Note You need to log in before you can comment on or make changes to this bug.