Bug 814449 - grub2-mkconfig hangs in os-prober
grub2-mkconfig hangs in os-prober
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 17:14 EDT by Susi Lehtola
Modified: 2012-04-30 06:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 17:16:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2012-04-19 17:14:48 EDT
The installation of Fedora 17 on my new desktop system hanged in the grub install. It turns out that the os-prober part of grub2-mkconfig hangs for some reason.

$ ps aux|grep grub
root      5207  0.0  0.0 112180  1620 pts/0    S+   00:10   0:00 /bin/sh /sbin/grub2-mkconfig
root      5458  0.0  0.0 112052  1516 pts/0    S+   00:10   0:00 /bin/sh /etc/grub.d/30_os-prober
root      5470  0.0  0.0 112052   656 pts/0    S+   00:10   0:00 /bin/sh /etc/grub.d/30_os-prober

During the install the prober had worked for 10+ minutes, and nothing had happened. My partitioning is

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x25afb2d5

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      718847      358400    7  HPFS/NTFS/exFAT
/dev/sda2          718848  1023999999   511640576    7  HPFS/NTFS/exFAT
/dev/sda3      1024000000  1025023999      512000   83  Linux
/dev/sda4      1025024000  3907028991  1441002496    5  Extended
/dev/sda5      1025028096  2663428095   819200000   83  Linux
/dev/sda6      2663430144  2790242303    63406080   83  Linux
/dev/sda7      2790244352  2790309887       32768   82  Linux swap / Solaris

and partitions 1 and 2 contain a Windows 7 installation (for playing Civilization V).


$ rpm -q grub2
grub2-1.99-19.fc17.x86_64
Comment 1 Susi Lehtola 2012-04-28 17:16:31 EDT
Well, this is fixed in grub2-2.0-0.24.beta4.fc17.x86_64.
Comment 2 Mads Kiilerich 2012-04-30 06:57:18 EDT
FWIW, I'm sure that it was something else than grub2 than fixed it:
https://bugzilla.redhat.com/show_bug.cgi?id=812914
https://bugzilla.redhat.com/show_bug.cgi?id=812798

Note You need to log in before you can comment on or make changes to this bug.