This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 814451 - samba4 makes a mess preventing updates
samba4 makes a mess preventing updates
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba4 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schneider
Fedora Extras Quality Assurance
:
: 814566 814685 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 17:22 EDT by Michal Jaegermann
Modified: 2012-05-22 20:27 EDT (History)
16 users (show)

See Also:
Fixed In Version: samba-3.6.5-86.fc17.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 10:51:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2012-04-19 17:22:19 EDT
Description of problem:

With libsmbsclient installed (a package required by numerous packages with
system-config-printer among those) and samba-winbind which depends on
samba-common an attempt to update the current rawhide installation goes like this:

---> Package libsmbclient.x86_64 1:3.6.4-82.fc18.1 will be updated
---> Package libsmbclient.x86_64 1:4.0.0-41alpha18.fc18 will be an update

All of this fells apart with:

Packages skipped because of dependency problems:
    libldb-1.1.4-2.fc17.x86_64 from rawhide
    1:libsmbclient-4.0.0-41alpha18.fc18.x86_64 from rawhide
    libtevent-0.9.15-1.fc18.x86_64 from rawhide
    pytalloc-2.0.7-4.fc17.x86_64 from rawhide
    1:samba4-client-4.0.0-41alpha18.fc18.x86_64 from rawhide
    1:samba4-common-4.0.0-41alpha18.fc18.x86_64 from rawhide
    1:samba4-dc-4.0.0-41alpha18.fc18.x86_64 from rawhide
    1:samba4-dc-libs-4.0.0-41alpha18.fc18.x86_64 from rawhide
    1:samba4-libs-4.0.0-41alpha18.fc18.x86_64 from rawhide

and the main reason seems to be this:
--> Processing Conflict: 1:samba4-common-4.0.0-41alpha18.fc18.x86_64 conflicts samba-common < 1:3.9.9

Regardless of that problem what if somebody has good reasons to keep samba on a 3.x level?  Sound not be 'libsmbclient4' available which is not an update
of libsmbclient-3....?  In such case it likely should provide 'libsmbclient' for use by other packages if samba4 is in use.

Version-Release number of selected component (if applicable):
samba4-4.0.0-41alpha18.fc18
samba-3.6.4-82.fc18.1
Comment 1 Fedora Update System 2012-04-20 10:06:38 EDT
samba4-4.0.0-42alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-42alpha18.fc17
Comment 2 Bruno Wolff III 2012-04-20 13:41:59 EDT
With libsmbclient4 changing to libsmbclient, I think that you either want samba4 to be parallel installable ti samba (3.x) or to have samba4 packages obsolete corresponding samba packages.
Comment 3 Alexander Bokovoy 2012-04-20 13:44:25 EDT
That's what we are trying to achieve -- until we are confident in full replacement, samba4 packages will be parallel installable.

Please look at the update mentioned in the comment 1 for build that tries to fix the issue.
Comment 4 Orion Poplawski 2012-04-20 14:19:11 EDT
*** Bug 814566 has been marked as a duplicate of this bug. ***
Comment 5 Bruno Wolff III 2012-04-20 14:47:06 EDT
I hadn't seen -42 yet.
Comment 6 Gene Snider 2012-04-20 15:59:20 EDT
While trying to update on April 20, 2012, I hit this bug.  While checking out local dependencies, I encountered the following oddity:

$ sudo yum list installed samba* *smb* libwb*
...
Installed Packages
gvfs-smb.x86_64                1.12.1-2.fc17                     @/gvfs-smb-1.12.1-2.fc17.x86_64
libsmbclient.x86_64            1:3.6.4-82.fc17.1                 @updates-testing               
libwbclient.x86_64             1:4.0.0-39alpha18.fc17            @updates-testing               
python-smbc.x86_64             1.0.13-1.fc17                     @anaconda-0                    
samba-client.x86_64            1:3.6.4-82.fc17.1                 @updates-testing               
samba-common.x86_64            1:3.6.4-82.fc17.1                 @updates-testing

]$ sudo yum history list libwbclient
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, remove-with-leaves, show-
              : leaves, verify
ID     | Login user               | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
    31 | Gene <gene>              | 2012-04-06 10:30 | Update         |   16   
     4 | Gene <gene>              | 2012-03-27 18:46 | I, U           |  231 EE
     1 | System <unset>           | 2012-03-27 17:00 | Install        | 1276

$ sudo yum history info *4*alpha*
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, remove-with-leaves, show-leaves, verify
Transaction ID : 31
Begin time     : Fri Apr  6 10:30:07 2012
Begin rpmdb    : 1371:fb85a7a8692e168ba527829df02b528a246879af
End time       :            10:31:38 2012 (91 seconds)
End rpmdb      : 1371:733078cd442356e4c23a3518c93921b82a9ef794
User           : Gene <gene>
Return-Code    : Success
Command Line   : update
Transaction performed with:
    Installed     rpm-4.9.1.3-1.fc17.x86_64                     @updates-testing
    Installed     yum-3.4.3-23.fc17.noarch                      @updates-testing
    Installed     yum-metadata-parser-1.1.4-6.fc17.x86_64       @anaconda-0
    Installed     yum-plugin-fastestmirror-1.1.31-4.fc17.noarch @fedora
    Installed     yum-presto-0.7.3-1.fc17.noarch                @updates-testing
Packages Altered:
...
    Updated libwbclient-1:3.6.3-81.fc17.1.x86_64            @updates-testing
    Update              1:4.0.0-39alpha18.fc17.x86_64       @updates-testing
...
history info

Apparently, the "sudo yum update" executed on April 6 pulled in the libwbclient package from samba4.  Since I'm not using samba, I don't see any issues.  But did this break winbind for a lot of users?

Gene
Comment 7 Gene Snider 2012-04-20 17:34:59 EDT
I just noticed this is filed against rawhide.  My previous comment is for F17, so perhaps the version should be expanded?

Gene
Comment 8 Nicolas Chauvet (kwizart) 2012-04-21 06:01:11 EDT
(In reply to comment #3)
> That's what we are trying to achieve -- until we are confident in full
> replacement, samba4 packages will be parallel installable.
> 
> Please look at the update mentioned in the comment 1 for build that tries to
> fix the issue.

It doesn't, package using BR: libsmbclient-devel are now linked with samba4 version whereas  a samba3 version still remains in the repos. This is an illegal package name clash.
My guess is that libsmbclient is not ABI compatible with the samba3 version.
At least it it internally requires SAMBA_4.0.0 symbols for most dependencies, so until you have removed most conflicts, it won't install on a system that default samba3.

I think you should revert e1d7e51c2d1d909b9bba4c1f94cc96605d7dbaca in F-17 samba4 and start working on a viable solution in F-18 first.
Then one need to rebuild package built with libsmbclient from samba4 such as gvfs.
Comment 9 Nicolas Chauvet (kwizart) 2012-04-21 06:34:29 EDT
Ok, I've miss-read the package version to test.
0.42alpha18 already has libsmbclient built internally within samba4-client.
As I don't expect an override was done, gvfs-smb was probably not built with samba4 after a second look. (at least not in F-17).
Comment 10 Timothy Davis 2012-04-21 12:25:37 EDT
Tried running yum update:
Error: samba4-common conflicts with 1:samba-common-3.6.4-82.fc17.1.x86_64
Error: samba4 conflicts with 1:samba-3.6.4-82.fc17.1.x86_64
Error: samba4-client conflicts with 1:samba-client-3.6.4-82.fc17.1.x86_64

Then ran yum update --skip-broken:
another error about multilib (lost the message)

Ended up removing samba and installing samba4
Comment 11 Fedora Update System 2012-04-21 17:01:34 EDT
Package samba4-4.0.0-42alpha18.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing samba4-4.0.0-42alpha18.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6303/samba4-4.0.0-42alpha18.fc17
then log in and leave karma (feedback).
Comment 12 Steve 2012-04-22 03:56:30 EDT
*** Bug 814685 has been marked as a duplicate of this bug. ***
Comment 13 Bruno Wolff III 2012-04-22 10:38:12 EDT
samba4 packages still conflict with samba packages in -42:
[root@cerberus bruno]# yum install -y -v samba4* | grep -i conflict
--> Processing Conflict: 1:samba4-client-4.0.0-42alpha18.fc17.x86_64 conflicts samba-client < 1:3.9.9
samba4-client conflicts with 1:samba-client-3.6.4-82.fc17.1.x86_64
--> Processing Conflict: 1:samba4-winbind-4.0.0-42alpha18.fc17.x86_64 conflicts samba-winbind < 1:3.9.9
samba4-winbind conflicts with 1:samba-winbind-3.6.4-82.fc17.1.x86_64
--> Processing Conflict: 1:samba4-winbind-clients-4.0.0-42alpha18.fc17.x86_64 conflicts samba-winbind-clients < 1:4.0.0-42alpha18.fc17
samba4-winbind-clients conflicts with 1:samba-winbind-clients-3.6.4-82.fc17.1.x86_64
--> Processing Conflict: 1:samba4-common-4.0.0-42alpha18.fc17.x86_64 conflicts samba-common < 1:3.9.9
samba4-common conflicts with 1:samba-common-3.6.4-82.fc17.1.x86_64
--> Processing Conflict: 1:samba4-4.0.0-42alpha18.fc17.x86_64 conflicts samba < 1:4.0.0-42alpha18.fc17
samba4 conflicts with 1:samba-3.6.4-82.fc17.1.x86_64
Comment 14 Alexander Bokovoy 2012-04-22 11:09:50 EDT
samba4 *should* conflict with samba, this is on purpose. What should not conflict is libsmbclient and libwbclient.

You simply should not install samba4 (daemons) package at this point if you want to have working smbd file serving and DC. Samba4 should be able to co-exist with libsmbclient/libwbclient to allow typical Desktop environment (which has gio/kde-kio plugins linked against libsmbclient) while developing FreeIPA v3 cross-realm trusts.
Comment 15 Bruno Wolff III 2012-04-22 11:38:22 EDT
Thanks. I was able to get the samba4 stuff installed instead of samba. I was just having trouble getting there from the previous state. The comment above told me what I needed to do to get there.
Comment 16 Susi Lehtola 2012-04-22 17:20:03 EDT
Now I'm getting

Error: Package: 1:libsmbclient-4.0.0-41alpha18.fc17.x86_64 (@updates-testing)
           Requires: samba4-common = 1:4.0.0-41alpha18.fc17
           Removing: 1:samba4-common-4.0.0-41alpha18.fc17.x86_64 (@updates-testing)
               samba4-common = 1:4.0.0-41alpha18.fc17
           Updated By: 1:samba4-common-4.0.0-42alpha18.fc17.x86_64 (updates-testing)
               samba4-common = 1:4.0.0-42alpha18.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 17 Simo Sorce 2012-04-22 17:35:09 EDT
I think your best bet is to yum downgrade libsmbclient so the 3.6 one is put back.
Comment 18 Andreas Schneider 2012-04-23 05:36:59 EDT
You can find the latest update addressing the issues at https://admin.fedoraproject.org/updates/samba4-4.0.0-42alpha18.fc17
Comment 19 Fedora Update System 2012-04-24 08:15:50 EDT
samba4-4.0.0-43alpha18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/samba4-4.0.0-43alpha18.fc17
Comment 20 Marko Myllynen 2012-04-24 10:56:23 EDT
FWIW, the -43 build fixed the update issue for me.
Comment 21 Michal Ambroz 2012-04-30 04:16:34 EDT
Buid 43 is not fixing for me as the versions of libsmbclient and samba4-common are out of sync.

Doing yum update today:
--> Running transaction check
---> Package samba4-client.x86_64 1:4.0.0-41alpha18.fc17 will be updated
---> Package samba4-client.x86_64 1:4.0.0-43alpha18.fc17 will be an update
---> Package samba4-common.x86_64 1:4.0.0-41alpha18.fc17 will be updated
--> Processing Dependency: samba4-common = 1:4.0.0-41alpha18.fc17 for package: 1:libsmbclient-4.0.0-41alpha18.fc17.x86_64
---> Package samba4-common.x86_64 1:4.0.0-43alpha18.fc17 will be an update
---> Package samba4-dc.x86_64 1:4.0.0-41alpha18.fc17 will be updated
---> Package samba4-dc.x86_64 1:4.0.0-43alpha18.fc17 will be an update
---> Package samba4-dc-libs.x86_64 1:4.0.0-41alpha18.fc17 will be updated
---> Package samba4-dc-libs.x86_64 1:4.0.0-43alpha18.fc17 will be an update
---> Package samba4-libs.x86_64 1:4.0.0-41alpha18.fc17 will be updated
---> Package samba4-libs.x86_64 1:4.0.0-43alpha18.fc17 will be an update
--> Finished Dependency Resolution
Error: Package: 1:libsmbclient-4.0.0-41alpha18.fc17.x86_64 (@updates-testing)
           Requires: samba4-common = 1:4.0.0-41alpha18.fc17
           Removing: 1:samba4-common-4.0.0-41alpha18.fc17.x86_64 (@updates-testing)
               samba4-common = 1:4.0.0-41alpha18.fc17
           Updated By: 1:samba4-common-4.0.0-43alpha18.fc17.x86_64 (updates-testing)
               samba4-common = 1:4.0.0-43alpha18.fc17
Comment 22 Pete Walter 2012-05-02 20:09:34 EDT
Getting the same error as in comment #21.
Comment 23 Andreas Schneider 2012-05-03 07:16:58 EDT
yum list libsmbclient

yum install libsmbclient-<version>

where the version should be 3.6.x and then run

yum update
Comment 24 Andreas Schneider 2012-05-03 11:52:31 EDT
There is no libsmbclient nor libwbclient package in Samba4. The ones from Samba3 need to be installed.
Comment 25 Pete Walter 2012-05-03 17:50:22 EDT
Seems there was a Samba4 version of libsmbclient at one point and this is what I have installed. You'll need to fix the packages so that upgrades work smoothly.

Instructions on how to manually accomplish that don't really help.
Comment 26 Andreas Schneider 2012-05-04 03:42:30 EDT
Yes, this was a mistake and our fault. 

But this update was only in in updates-testing. And as I understand it is to test updates. If this isn't true then it should be removed. From my point of view F17 is still beta and in development. If there is no room for mistakes in development then something is wrong with this distribution development model.

As a beta tester I think you're smart guys who can solve such a packaging mistake easily.

Just install libsmbclient and libwbclient from Samba3 again and all problems are solved.
Comment 27 Need Real Name 2012-05-04 13:32:28 EDT
I'm sure enough you're a smart guy who is smart enough to solve this automatically for all users.

Don't we have packaging guidelines and fesco for cases like this?

Note You need to log in before you can comment on or make changes to this bug.