Bug 814461 - SELinux is preventing lsb_release from 'getattr' accesses on the file /proc/meminfo.
SELinux is preventing lsb_release from 'getattr' accesses on the file /proc/m...
Status: CLOSED DUPLICATE of bug 814462
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7f08c5107331b47885c8effeed7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 18:22 EDT by geminic86
Modified: 2012-04-20 04:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 04:28:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-04-19 18:22:28 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.1-5.fc16.i686
reason:         SELinux is preventing lsb_release from 'getattr' accesses on the file /proc/meminfo.
time:           Thu 19 Apr 2012 06:22:14 PM EDT

description:
:SELinux is preventing lsb_release from 'getattr' accesses on the file /proc/meminfo.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that lsb_release should be allowed getattr access on the meminfo file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep lsb_release /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:cfengine_monitord_t:s0
:Target Context                system_u:object_r:proc_t:s0
:Target Objects                /proc/meminfo [ file ]
:Source                        lsb_release
:Source Path                   lsb_release
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-5.fc16.i686 #1 SMP Tue Apr 10
:                              20:55:58 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Thu 19 Apr 2012 06:09:12 PM EDT
:Last Seen                     Thu 19 Apr 2012 06:09:12 PM EDT
:Local ID                      2e0b281e-daa1-476a-983a-8c0e2b9629c4
:
:Raw Audit Messages
:type=AVC msg=audit(1334873352.651:21689): avc:  denied  { getattr } for  pid=16273 comm="lsb_release" path="/proc/meminfo" dev="proc" ino=4026532028 scontext=system_u:system_r:cfengine_monitord_t:s0 tcontext=system_u:object_r:proc_t:s0 tclass=file
:
:
:Hash: lsb_release,cfengine_monitord_t,proc_t,file,getattr
:
:audit2allow
:
:#============= cfengine_monitord_t ==============
:allow cfengine_monitord_t proc_t:file getattr;
:
:audit2allow -R
:
:#============= cfengine_monitord_t ==============
:allow cfengine_monitord_t proc_t:file getattr;
:
Comment 1 Miroslav Grepl 2012-04-20 04:28:06 EDT

*** This bug has been marked as a duplicate of bug 814462 ***

Note You need to log in before you can comment on or make changes to this bug.