Bug 814462 - SELinux is preventing cf-monitord from read, open access on the file /bin/bash.
SELinux is preventing cf-monitord from read, open access on the file /bin/bash.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9a24bc61d67e0ade2aa4fa948ee...
:
: 814460 814461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 18:22 EDT by geminic86
Modified: 2012-06-22 09:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 09:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-04-19 18:22:55 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.1-5.fc16.i686
reason:         SELinux is preventing cf-monitord from read, open access on the file /bin/bash.
time:           Thu 19 Apr 2012 06:22:45 PM EDT

description:
:SELinux is preventing cf-monitord from read, open access on the file /bin/bash.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that cf-monitord should be allowed read open access on the bash file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep cf-monitord /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:cfengine_monitord_t:s0
:Target Context                system_u:object_r:shell_exec_t:s0
:Target Objects                /bin/bash [ file ]
:Source                        cf-monitord
:Source Path                   cf-monitord
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           bash-4.2.24-1.fc16.i686
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-5.fc16.i686 #1 SMP Tue Apr 10
:                              20:55:58 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Thu 19 Apr 2012 06:09:12 PM EDT
:Last Seen                     Thu 19 Apr 2012 06:09:12 PM EDT
:Local ID                      659fd76a-a308-47d9-a7ee-e1e165c86ba6
:
:Raw Audit Messages
:type=AVC msg=audit(1334873352.649:21686): avc:  denied  { read open } for  pid=16273 comm="cf-monitord" name="bash" dev="dm-1" ino=27820 scontext=system_u:system_r:cfengine_monitord_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file
:
:
:Hash: cf-monitord,cfengine_monitord_t,shell_exec_t,file,read,open
:
:audit2allow
:
:#============= cfengine_monitord_t ==============
:allow cfengine_monitord_t shell_exec_t:file { read open };
:
:audit2allow -R
:
:#============= cfengine_monitord_t ==============
:allow cfengine_monitord_t shell_exec_t:file { read open };
:
Comment 1 Miroslav Grepl 2012-04-20 04:28:07 EDT
*** Bug 814461 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-20 04:28:17 EDT
*** Bug 814460 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-04-20 04:30:03 EDT
Fixed in selinux-policy-3.10.0-85.fc16

A new build will be available today from koji.

Note You need to log in before you can comment on or make changes to this bug.