Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 814559 - Error while uploading sources
Summary: Error while uploading sources
Keywords:
Status: CLOSED DUPLICATE of bug 816036
Alias: None
Product: Fedora
Classification: Fedora
Component: 0xFFFF
Version: 17
Hardware: All
OS: Linux
high
urgent
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-20 06:37 UTC by Krzysztof Daniel
Modified: 2014-01-13 00:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-08 06:24:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Krzysztof Daniel 2012-04-20 06:37:07 UTC
What steps will reproduce the problem?
1. 
2. 
3. 


-- Error Details --
Date: Fri Apr 20 08:36:03 CEST 2012
Message: An internal error occurred during: "Uploading Sources".
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.core.jobs
Session Data:
eclipse.buildId=I20120417-1000
java.version=1.7.0_b147-icedtea
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

Exception Stack Trace:
java.lang.LinkageError: loader constraint violation: when resolving method "org.apache.http.impl.client.DefaultHttpClient.<init>(Lorg/apache/http/params/HttpParams;)V" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/fedoraproject/eclipse/packager/api/UploadSourceCommand, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, org/apache/http/impl/client/DefaultHttpClient, have different Class objects for the type /http/params/HttpParams;)V used in the signature
	at org.fedoraproject.eclipse.packager.api.UploadSourceCommand.getClient(UploadSourceCommand.java:414)
	at org.fedoraproject.eclipse.packager.api.UploadSourceCommand.checkSourceAvailable(UploadSourceCommand.java:226)
	at org.fedoraproject.eclipse.packager.api.UploadSourceCommand.call(UploadSourceCommand.java:193)
	at org.fedoraproject.eclipse.packager.internal.handlers.UploadHandler$1.run(UploadHandler.java:152)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Comment 1 Krzysztof Daniel 2012-05-08 06:24:53 UTC

*** This bug has been marked as a duplicate of bug 816036 ***


Note You need to log in before you can comment on or make changes to this bug.