Bug 814614 - [ALL_Lang] [virt-manager] Unlocalized string 'System policy prevents management of local virtualized systems' in Authenticate dialog.
[ALL_Lang] [virt-manager] Unlocalized string 'System policy prevents manageme...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
: Translation
: 814616 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 05:13 EDT by Lijun Li
Modified: 2012-09-11 21:39 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 21:39:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized string 'System policy prevents management of local virtualized systems' in Authenticate dialog (52.36 KB, image/png)
2012-04-20 05:15 EDT, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-04-20 05:13:22 EDT
Description of problem:
Unlocalized string 'System policy prevents management of local virtualized systems' in Authenticate dialog

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-11.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install latest RHEL6.3 Client build.(Ex. RHEL-6.3-Beta-1.1).
2. Install virt-manager, run virt-manager from terminal or Applications -> System Tools -> Virtual Machine Manager.

  
Actual results:
Unlocalized string 'System policy prevents management of local virtualized systems' in Authenticate dialog

Expected results:
String'System policy prevents management of local virtualized systems' should be localized. 

Additional info:
Comment 1 Lijun Li 2012-04-20 05:15:05 EDT
Created attachment 578928 [details]
Unlocalized string 'System policy prevents management of local virtualized systems' in Authenticate dialog
Comment 3 A S Alam 2012-04-23 02:03:31 EDT
Various languages needs translation update:
-----
virt-manager
as:
677 translated messages.
bn_IN:
834 translated messages.
de:
849 translated messages.
es:
877 translated messages.
fr:
955 translated messages.
gu:
905 translated messages.
hi:
705 translated messages.
it:
713 translated messages.
ja:
876 translated messages.
kn:
835 translated messages.
ko:
834 translated messages.
mr:
834 translated messages.
ml:
834 translated messages.
or:
834 translated messages.
pa:
876 translated messages.
pt_BR:
278 translated messages.
ru:
849 translated messages.
ta:
706 translated messages.
te:
834 translated messages.
zh_CN:
717 translated messages.
zh_TW:
275 translated messages
Comment 4 Ankit Patel 2012-04-24 06:34:53 EDT
Two things.

1. As reported in Comment #0, the message "System policy prevents management of local virtualized systems" seems untranslated, but actually it's not available for translations, basically the message might not be marked for translation hence the POT/POs are outdated. : https://www.transifex.net/projects/p/virt-manager/

Can you please make sure the POT/POs are latest?

2. As reported in Comment #3, translation statistics vary for Red Hat supported languages while all of them are 100% translated as you can see here: https://www.transifex.net/projects/p/virt-manager/

Can you please check this as well?

Now, are we supposed to provide translation updates to : https://www.transifex.net/projects/p/virt-manager/ OR a patch is acceptable?

Thanks!
Ankit
Comment 5 Cole Robinson 2012-04-25 12:39:23 EDT
*** Bug 814616 has been marked as a duplicate of this bug. ***
Comment 6 Cole Robinson 2012-04-25 12:41:27 EDT
(In reply to comment #4)
> Two things.
> 
> 1. As reported in Comment #0, the message "System policy prevents management of
> local virtualized systems" seems untranslated, but actually it's not available
> for translations, basically the message might not be marked for translation
> hence the POT/POs are outdated. :
> https://www.transifex.net/projects/p/virt-manager/
> 

That message comes from policykit-gnome agent, not virt-manager.

> Can you please make sure the POT/POs are latest?
> 
> 2. As reported in Comment #3, translation statistics vary for Red Hat supported
> languages while all of them are 100% translated as you can see here:
> https://www.transifex.net/projects/p/virt-manager/
> 
> Can you please check this as well?
> 
> Now, are we supposed to provide translation updates to :
> https://www.transifex.net/projects/p/virt-manager/ OR a patch is acceptable?
> 

Problem is that transifex tracks upstream code, which is different from RHEL6
code. So we can't just pull the transifex updates since it won't correctly
match up with RHEL6 strings. So I think a patch is the only way.
Comment 13 Dave Allan 2012-09-11 21:39:17 EDT
Patches should be submitted upstream.

Note You need to log in before you can comment on or make changes to this bug.